summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiwoong Im <jiwoong.im@samsung.com>2015-05-11 19:09:13 +0900
committerJiwoong Im <jiwoong.im@samsung.com>2015-05-11 19:10:37 +0900
commit9a0555bde72a469e8eef1fd225d0ca0d52506477 (patch)
tree9b48a60a266f2f1cac4eaf657d105c08de7e9859 /CMakeLists.txt
parentb50461629ddb1287f2bd5662dba9a6e2fdf88b5a (diff)
downloadappcore-agent-9a0555bde72a469e8eef1fd225d0ca0d52506477.tar.gz
appcore-agent-9a0555bde72a469e8eef1fd225d0ca0d52506477.tar.bz2
appcore-agent-9a0555bde72a469e8eef1fd225d0ca0d52506477.zip
To fix build break in application from tizen 2.4 Change-Id: I074c83062dfdd5ad175a5645bb981a31c08ff47a Signed-off-by: Jiwoong Im <jiwoong.im@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3816369..dae38e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,10 @@ CONFIGURE_FILE(${APPCORE_AGENT}.pc.in ${APPCORE_AGENT}.pc @ONLY)
INSTALL(TARGETS ${APPCORE_AGENT} DESTINATION ${LIB_INSTALL_DIR} COMPONENT RuntimeLibraries)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${APPCORE_AGENT}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+
+CONFIGURE_FILE(capi-appfw-service-application.pc.in capi-appfw-service-application.pc @ONLY)
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/capi-appfw-service-application.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+
FOREACH(hfile ${HEADERS_agent})
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/include/${hfile} DESTINATION include/appcore-agent)
ENDFOREACH(hfile)