summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMayank Haarit <mayank.h@samsung.com>2018-12-27 21:39:25 +0530
committerMayank Haarit <mayank.h@samsung.com>2018-12-27 21:55:18 +0530
commit7ef316cc98cadc0839b7d5295d5855e66a9f6a57 (patch)
tree3e542b5eaf55f0539803fe8b6a28b1752c9facbf /CMakeLists.txt
parent8f86ca887d1bfe940347ca1a70d41ef982febae3 (diff)
downloaduser-awareness-7ef316cc98cadc0839b7d5295d5855e66a9f6a57.tar.gz
user-awareness-7ef316cc98cadc0839b7d5295d5855e66a9f6a57.tar.bz2
user-awareness-7ef316cc98cadc0839b7d5295d5855e66a9f6a57.zip
Implement monitoring, event handling functionalities
This patch includes following implemenation: 1) Handle events from UAFW daemon a) PRESENCE detection b) ABSENCE detection c) Add user d) Remove user e) Add device f) Remove device g) Sensor state ready h) Sensor state not ready 2) Monitoring a) Start Presence/Absence detection b) Stop Presence/Absence detection 3) Unit test to development to validate UAFW 4) Added ua_monitor_set_brightness_threshold 5) Added ua_device_get_pairing_required Signed-off-by: Mayank Haarit <mayank.h@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a0b6ef..6657dfd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,4 +74,4 @@ CONFIGURE_FILE(
)
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${LIB_NAME}.pc DESTINATION ${LIB_PKGCONFIG_DIR})
-#ADD_SUBDIRECTORY(test)
+ADD_SUBDIRECTORY(test)