summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-01-07 00:50:19 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-01-07 00:50:19 +0900
commitf82d616f46273ffbb9f043ad162b8d6f1c6d410d (patch)
tree013875b2cdcbc0e5c404dc284b5c295592d032bb /debian
parentbbe023c911411370c4896540a424a455885cc87b (diff)
downloadnotification-f82d616f46273ffbb9f043ad162b8d6f1c6d410d.tar.gz
notification-f82d616f46273ffbb9f043ad162b8d6f1c6d410d.tar.bz2
notification-f82d616f46273ffbb9f043ad162b8d6f1c6d410d.zip
Git init
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog16
-rwxr-xr-xdebian/compat1
-rwxr-xr-xdebian/control27
-rwxr-xr-xdebian/libnotification-0.install.in1
-rwxr-xr-xdebian/libnotification-0.postinst.in92
-rwxr-xr-xdebian/libnotification-dev.install.in2
-rwxr-xr-xdebian/rules116
7 files changed, 255 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..8f686ab
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,16 @@
+libnotification (0.1.1-4) unstable; urgency=low
+
+ * Update pkgname to org.tizen
+ * Git: pkgs/n/notification
+ * Tag: libnotification_0.1.1-4
+
+ -- Mi-Ju Lee <miju52.lee@samsung.com> Fri, 23 Dec 2011 15:56:33 +0900
+
+libnotification (0.1.1-3) unstable; urgency=low
+
+ * Initial Release
+ * Git: pkgs/n/notification
+ * Tag: libnotification_0.1.1-3
+
+ -- Mi-Ju Lee <miju52.lee@samsung.com> Wed, 07 Dec 2011 11:13:10 +0900
+
diff --git a/debian/compat b/debian/compat
new file mode 100755
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..d1060e9
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,27 @@
+Source: libnotification
+Section: libs
+Priority: optional
+Maintainer: Seungtaek Chung <seungtaek.chung@samsung.com>, Mi-Ju Lee <miju52.lee@samsung.com>, Xi Zhichan <zhichan.xi@samsung.com>
+Build-Depends: debhelper (>= 5), libsqlite3-dev, libslp-db-util-dev, libheynoti-dev, libvconf-dev, libbundle-dev, libdbus-1-dev, dlog-dev, libail-0-dev, libaul-1-dev, libappsvc-dev
+Standards-Version: 3.7.2
+
+Package: libnotification-dev
+Section: libdevel
+Architecture: any
+Depends: libnotification-0 (= ${Source-Version}), libsqlite3-dev, libslp-db-util-dev, libheynoti-dev, libvconf-dev, libbundle-dev, dlog-dev, libail-0-dev, libaul-1-dev
+Description: Notification library
+ This package contains devel content.
+
+Package: libnotification-0
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, sqlite3, libdlog-0
+Description: Notification library
+ This package contains notification library.
+
+Package: libnotification-dbg
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, libnotification-0 (= ${Source-Version})
+Description: Notification library
+ This package is for debug
diff --git a/debian/libnotification-0.install.in b/debian/libnotification-0.install.in
new file mode 100755
index 0000000..bf766f0
--- /dev/null
+++ b/debian/libnotification-0.install.in
@@ -0,0 +1 @@
+@PREFIX@/lib/*.so*
diff --git a/debian/libnotification-0.postinst.in b/debian/libnotification-0.postinst.in
new file mode 100755
index 0000000..fcf05fb
--- /dev/null
+++ b/debian/libnotification-0.postinst.in
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+
+if [ ! -d @DATADIR@/dbspace ]
+then
+ mkdir @DATADIR@/dbspace
+fi
+
+if [ ! -f @DATADIR@/dbspace/.notification.db ]
+then
+ sqlite3 @DATADIR@/dbspace/.notification.db 'PRAGMA journal_mode = PERSIST;
+ create table if not exists noti_list (
+ type INTEGER NOT NULL,
+ caller_pkgname TEXT NOT NULL,
+ launch_pkgname TEXT,
+ image_path TEXT,
+ group_id INTEGER default 0,
+ internal_group_id INTEGER default 0,
+ priv_id INTERGER NOT NULL,
+ title_key TEXT,
+ b_text TEXT,
+ b_key TEXT,
+ b_format_args TEXT,
+ num_format_args INTEGER default 0,
+ text_domain TEXT,
+ text_dir TEXT,
+ time INTEGER default 0,
+ insert_time INTEGER default 0,
+ args TEXT,
+ group_args TEXT,
+ b_execute_option TEXT,
+ b_service_responding TEXT,
+ b_service_single_launch TEXT,
+ b_service_multi_launch TEXT,
+ sound_type INTEGER default 0,
+ sound_path TEXT,
+ vibration_type INTEGER default 0,
+ vibration_path TEXT,
+ flags_for_property INTEGER default 0,
+ flag_simmode INTEGER default 0,
+ display_applist INTEGER,
+ progress_size DOUBLE default 0,
+ progress_percentage DOUBLE default 0,
+ rowid INTEGER PRIMARY KEY AUTOINCREMENT,
+ UNIQUE (caller_pkgname, priv_id)
+ );
+ create table if not exists noti_group_data (
+ caller_pkgname TEXT NOT NULL,
+ group_id INTEGER default 0,
+ badge INTEGER default 0,
+ title TEXT,
+ content TEXT,
+ loc_title TEXT,
+ loc_content TEXT,
+ count_display_title INTEGER,
+ count_display_content INTEGER,
+ rowid INTEGER PRIMARY KEY AUTOINCREMENT,
+ UNIQUE (caller_pkgname, group_id)
+ );
+ create table if not exists ongoing_list (
+ caller_pkgname TEXT NOT NULL,
+ launch_pkgname TEXT,
+ icon_path TEXT,
+ group_id INTEGER default 0,
+ internal_group_id INTEGER default 0,
+ priv_id INTERGER NOT NULL,
+ title TEXT,
+ content TEXT,
+ default_content TEXT,
+ loc_title TEXT,
+ loc_content TEXT,
+ loc_default_content TEXT,
+ text_domain TEXT,
+ text_dir TEXT,
+ args TEXT,
+ group_args TEXT,
+ flag INTEGER default 0,
+ progress_size DOUBLE default 0,
+ progress_percentage DOUBLE default 0,
+ rowid INTEGER PRIMARY KEY AUTOINCREMENT,
+ UNIQUE (caller_pkgname, priv_id)
+ );
+ '
+fi
+
+if [ ${USER} = "root" ]
+then
+ chown root:5000 @DATADIR@/dbspace/.notification.db
+ chown root:5000 @DATADIR@/dbspace/.notification.db-journal
+fi
+chmod 660 @DATADIR@/dbspace/.notification.db
+chmod 660 @DATADIR@/dbspace/.notification.db-journal
diff --git a/debian/libnotification-dev.install.in b/debian/libnotification-dev.install.in
new file mode 100755
index 0000000..0f2a4da
--- /dev/null
+++ b/debian/libnotification-dev.install.in
@@ -0,0 +1,2 @@
+@PREFIX@/include/*
+@PREFIX@/lib/pkgconfig/*.pc
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8cd299e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,116 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS ?= -Wall -g
+CXXFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DATADIR ?= /opt
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+ CXXFLAGS += -O0
+else
+ CFLAGS += -O2
+ CXXFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && \
+ CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" cmake .. -DCMAKE_INSTALL_PREFIX=$(PREFIX)
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ cd $(CMAKE_BUILD_DIR) && $(MAKE)
+
+ #docbook-to-man debian/wavplayer.sgml > wavplayer.1
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ rm -rf $(CMAKE_BUILD_DIR)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wavplayer.
+ cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip --dbg-package=libnotification-dbg
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure