summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSeokHoon Lee <andy.shlee@samsung.com>2015-12-28 11:12:18 +0900
committerSeokHoon Lee <andy.shlee@samsung.com>2015-12-28 11:15:56 +0900
commitefbda6c1245893a928180ea573bd4222bc730e25 (patch)
tree989ac6775ae53064140437d8ca7b0e2135ec23d6 /CMakeLists.txt
parent97aa7477e98a4ae40576ad49fb30960b5947d66d (diff)
downloadmediavision-efbda6c1245893a928180ea573bd4222bc730e25.tar.gz
mediavision-efbda6c1245893a928180ea573bd4222bc730e25.tar.bz2
mediavision-efbda6c1245893a928180ea573bd4222bc730e25.zip
Signed-off-by: SeokHoon Lee <andy.shlee@samsung.com> Change-Id: I3021c9b6081812f178d5ff78ad92387b4cad0763
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49c3ed3b..5898b983 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,6 @@ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
# Configure for porting layer:
-# Configure for porting layer:
-
option(MEDIA_VISION_BARCODE_DETECTOR_LICENSE_PORT
"Turn on building of licensed port of the barcode detecting module (if OFF - open port will be built)." OFF)
option(MEDIA_VISION_BARCODE_GENERATOR_LICENSE_PORT
@@ -117,12 +115,12 @@ ADD_SUBDIRECTORY(mv_surveillance)
aux_source_directory(src SOURCES)
ADD_LIBRARY(${fw_name} SHARED ${SOURCES})
-TARGET_LINK_LIBRARIES(${fw_name} ${MV_COMMON_LIB_NAME}
+TARGET_LINK_LIBRARIES(${fw_name} ${${fw_name}_LDFLAGS}
+ ${MV_COMMON_LIB_NAME}
${MV_BARCODE_DETECTOR_LIB_NAME}
${MV_BARCODE_GENERATOR_LIB_NAME}
${MV_IMAGE_LIB_NAME}
${MV_FACE_LIB_NAME}
- ${${fw_name}_LDFLAGS}
${MV_SURVEILLANCE_LIB_NAME})
SET_TARGET_PROPERTIES(${fw_name}