summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 4 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 616bfa2..575a986 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,11 +9,7 @@ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
SET(INC_DIR include)
INCLUDE_DIRECTORIES(${INC_DIR})
-IF (TIZEN_PROFILE_TV)
- SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api db-util")
-ELSE ()
- SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api")
-ENDIF (TIZEN_PROFILE_TV)
+SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api db-util")
SET(pc_dependents "capi-base-common glib-2.0")
INCLUDE(FindPkgConfig)
@@ -34,24 +30,7 @@ ADD_DEFINITIONS("-DTIZEN_DEBUG")
SET(CMAKE_EXE_LINKER_FLAGS "-Wl,--as-needed -Wl,--rpath=${LIB_INSTALL_DIR}")
-IF (TIZEN_PROFILE_TV)
-SET(SOURCES
-src/bluetooth-common.c
-src/bluetooth-adapter.c
-src/bluetooth-device.c
-src/bluetooth-socket.c
-src/bluetooth-opp-server.c
-src/bluetooth-opp-client.c
-src/bluetooth-pan.c
-src/bluetooth-hdp.c
-src/bluetooth-hid.c
-src/bluetooth-audio.c
-src/bluetooth-avrcp.c
-src/bluetooth-gatt.c
-src/bluetooth-ipsp.c
-src/bluetooth-dpm.c
-)
-ELSE ()
+
SET(SOURCES
src/bluetooth-common.c
src/bluetooth-adapter.c
@@ -67,12 +46,10 @@ src/bluetooth-avrcp.c
src/bluetooth-gatt.c
src/bluetooth-ipsp.c
src/bluetooth-dpm.c
-src/bluetooth-proximity.c
)
-IF (TIZEN_PROFILE_WEARABLE OR TIZEN_PROFILE_IVI)
+
+LIST(APPEND SOURCES src/bluetooth-proximity.c)
LIST(APPEND SOURCES src/bluetooth-pbap.c)
-ENDIF (TIZEN_PROFILE_WEARABLE OR TIZEN_PROFILE_IVI)
-ENDIF (TIZEN_PROFILE_TV)
ADD_LIBRARY(${fw_name} SHARED ${SOURCES})
@@ -105,10 +82,7 @@ CONFIGURE_FILE(
)
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${fw_name}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-IF (TIZEN_PROFILE_TV)
-ELSE ()
ADD_SUBDIRECTORY(test)
-ENDIF (TIZEN_PROFILE_TV)
IF(UNIX)