summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMyungJoo Ham <myungjoo.ham@samsung.com>2016-12-02 16:52:04 +0900
committerMyungJoo Ham <myungjoo.ham@samsung.com>2016-12-05 10:38:35 +0900
commitebdb6d1c4559c3384f25a60226b796bb8c43961a (patch)
treef3439e7ca405fdd4214f328cf0368b2294e4d158 /CMakeLists.txt
parentc434b5580eb51f9d59e0dd514f63697fcbf43a33 (diff)
downloadbluetooth-ebdb6d1c4559c3384f25a60226b796bb8c43961a.tar.gz
bluetooth-ebdb6d1c4559c3384f25a60226b796bb8c43961a.tar.bz2
bluetooth-ebdb6d1c4559c3384f25a60226b796bb8c43961a.zip
Remove Profile Build Dependency: do it at runtime
- This is for Tizen 4.0. : Tizen 4.0 Configurability and Build Blocks require to remove all profile-depending build options in spec files. (No More profile macros) - It is recommended to distinguish features/profiles at runtime. unless it incurs too much overhead, which requires you to create multiple binaries and subpackages. - If you intent not to have capi-network-bluetooth-test.rpm in TV profile, please create a JIRA-TRE issue of package removal, not %if TV; test fiels; #endif. Change-Id: I2d80c4745202c028ca5c2a2f1662933c60d38b33 Signed-off-by: MyungJoo Ham <myungjoo.ham@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 4 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 616bfa2..575a986 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,11 +9,7 @@ SET(PREFIX ${CMAKE_INSTALL_PREFIX})
SET(INC_DIR include)
INCLUDE_DIRECTORIES(${INC_DIR})
-IF (TIZEN_PROFILE_TV)
- SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api db-util")
-ELSE ()
- SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api")
-ENDIF (TIZEN_PROFILE_TV)
+SET(dependents "dlog glib-2.0 capi-base-common capi-system-info bluetooth-api db-util")
SET(pc_dependents "capi-base-common glib-2.0")
INCLUDE(FindPkgConfig)
@@ -34,24 +30,7 @@ ADD_DEFINITIONS("-DTIZEN_DEBUG")
SET(CMAKE_EXE_LINKER_FLAGS "-Wl,--as-needed -Wl,--rpath=${LIB_INSTALL_DIR}")
-IF (TIZEN_PROFILE_TV)
-SET(SOURCES
-src/bluetooth-common.c
-src/bluetooth-adapter.c
-src/bluetooth-device.c
-src/bluetooth-socket.c
-src/bluetooth-opp-server.c
-src/bluetooth-opp-client.c
-src/bluetooth-pan.c
-src/bluetooth-hdp.c
-src/bluetooth-hid.c
-src/bluetooth-audio.c
-src/bluetooth-avrcp.c
-src/bluetooth-gatt.c
-src/bluetooth-ipsp.c
-src/bluetooth-dpm.c
-)
-ELSE ()
+
SET(SOURCES
src/bluetooth-common.c
src/bluetooth-adapter.c
@@ -67,12 +46,10 @@ src/bluetooth-avrcp.c
src/bluetooth-gatt.c
src/bluetooth-ipsp.c
src/bluetooth-dpm.c
-src/bluetooth-proximity.c
)
-IF (TIZEN_PROFILE_WEARABLE OR TIZEN_PROFILE_IVI)
+
+LIST(APPEND SOURCES src/bluetooth-proximity.c)
LIST(APPEND SOURCES src/bluetooth-pbap.c)
-ENDIF (TIZEN_PROFILE_WEARABLE OR TIZEN_PROFILE_IVI)
-ENDIF (TIZEN_PROFILE_TV)
ADD_LIBRARY(${fw_name} SHARED ${SOURCES})
@@ -105,10 +82,7 @@ CONFIGURE_FILE(
)
INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${fw_name}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-IF (TIZEN_PROFILE_TV)
-ELSE ()
ADD_SUBDIRECTORY(test)
-ENDIF (TIZEN_PROFILE_TV)
IF(UNIX)