summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiwoong Im <jiwoong.im@samsung.com>2014-12-30 20:30:59 +0900
committerJiwoong Im <jiwoong.im@samsung.com>2014-12-30 21:16:11 +0900
commit001fb68b65c4f1c6b93569723c558f687a18f68b (patch)
treedb12f14f44dcd3795012d82161907eb9da364c68 /CMakeLists.txt
parent4383609dbe3f4b43240030d392bb1b81aef22b0f (diff)
downloadapplication-001fb68b65c4f1c6b93569723c558f687a18f68b.tar.gz
application-001fb68b65c4f1c6b93569723c558f687a18f68b.tar.bz2
application-001fb68b65c4f1c6b93569723c558f687a18f68b.zip
Add new api for system event handling from tizen_2.3
Remove system event callbacks except related application lifecycle. The system event callbacks can be registered using ui_app_add_event_handler(). Multiple system event callbacks can be registered. The application main loop api is renamed to ui_app_main. app_event_get_xxx provides apis for getting system event information. Change-Id: Ib24f8bb46038fc6a4b50c2516e846cfc27e7acfd Signed-off-by: Jiwoong Im <jiwoong.im@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ce05ad..df7f5df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ SET(INC_DIR include)
INCLUDE_DIRECTORIES(${INC_DIR})
SET(requires "dlog bundle appcore-common appcore-efl aul ail appsvc notification elementary capi-base-common alarm-service sqlite3 libtzplatform-config")
-SET(pc_requires "capi-base-common")
+SET(pc_requires "capi-base-common vconf-internal-keys")
INCLUDE(FindPkgConfig)
pkg_check_modules(${fw_name} REQUIRED ${requires})