summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJiwoong Im <jiwoong.im@samsung.com>2015-05-26 17:55:30 +0900
committerJiwoong Im <jiwoong.im@samsung.com>2015-05-26 17:59:44 +0900
commitc96b20ac5256879e40e4e5ac49b3d01531e5c062 (patch)
tree9cca7814c53de02fe6198e360a81c6e72d380c0f /CMakeLists.txt
parent30092aebab638aeeef491a92801f71f658f66e6a (diff)
downloadapplication-c96b20ac5256879e40e4e5ac49b3d01531e5c062.tar.gz
application-c96b20ac5256879e40e4e5ac49b3d01531e5c062.tar.bz2
application-c96b20ac5256879e40e4e5ac49b3d01531e5c062.zip
Add event system api.
Add new api (add/remove event handler and publish user event) for native application. - new api list event_add_event_handler() event_remove_event_handler() event_publish_app_event() event_publish_trusted_app_event() JIRA ticket : TC-2473 Change-Id: I6ac68ecf85cc3db45a79c91abe6525d59e33564a Signed-off-by: Jiwoong Im <jiwoong.im@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c201a07..f920faa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ SET(INC_DIR include)
INCLUDE_DIRECTORIES(${INC_DIR})
SET(requires "dlog bundle appcore-common appcore-efl aul ail appsvc elementary capi-base-common alarm-service sqlite3 libtzplatform-config")
-SET(pc_requires "capi-base-common vconf-internal-keys capi-appfw-alarm capi-appfw-app-control capi-appfw-app-common capi-appfw-preference")
+SET(pc_requires "capi-base-common vconf-internal-keys capi-appfw-alarm capi-appfw-app-control capi-appfw-app-common capi-appfw-preference capi-appfw-event")
INCLUDE(FindPkgConfig)
pkg_check_modules(${fw_name} REQUIRED ${requires})
@@ -37,8 +37,9 @@ ADD_SUBDIRECTORY(app_control)
ADD_SUBDIRECTORY(app_common)
ADD_SUBDIRECTORY(alarm)
ADD_SUBDIRECTORY(preference)
+ADD_SUBDIRECTORY(event)
-TARGET_LINK_LIBRARIES(${fw_name} capi-appfw-app-control capi-appfw-app-common capi-appfw-alarm capi-appfw-preference ${${fw_name}_LDFLAGS})
+TARGET_LINK_LIBRARIES(${fw_name} capi-appfw-app-control capi-appfw-app-common capi-appfw-alarm capi-appfw-preference capi-appfw-event ${${fw_name}_LDFLAGS})
SET_TARGET_PROPERTIES(${fw_name}
PROPERTIES