summaryrefslogtreecommitdiff
path: root/packaging/system-plugin.spec
diff options
context:
space:
mode:
authorSuchang Woo <suchang.woo@samsung.com>2015-03-17 15:58:17 +0900
committerSuchang Woo <suchang.woo@samsung.com>2015-03-18 21:24:38 +0900
commit8d40e831f8d5534be16d3ce6cc8ce44746b5b26a (patch)
tree52723e2e00d1f460d6e9c4e6534b6165e58cbd44 /packaging/system-plugin.spec
parent63f36a36bbf6e45b2cf419113b3b5e3d9752ecec (diff)
downloadsystem-plugin-8d40e831f8d5534be16d3ce6cc8ce44746b5b26a.tar.gz
system-plugin-8d40e831f8d5534be16d3ce6cc8ce44746b5b26a.tar.bz2
system-plugin-8d40e831f8d5534be16d3ce6cc8ce44746b5b26a.zip
Add spec, license and systemd unit files
system-plugin and system-plugin-u3 packages are defined in .spec file. system-plugin package provides common files. and, system-plugin-u3 package provides files which are used only for U3/XU3 target. Signed-off-by: Suchang Woo <suchang.woo@samsung.com> Change-Id: Ied345423c7cee77219be52c73bc014b96efc4cc2
Diffstat (limited to 'packaging/system-plugin.spec')
-rw-r--r--packaging/system-plugin.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/packaging/system-plugin.spec b/packaging/system-plugin.spec
new file mode 100644
index 0000000..cf03d71
--- /dev/null
+++ b/packaging/system-plugin.spec
@@ -0,0 +1,54 @@
+%define debug_package %{nil}
+
+Name: system-plugin
+Summary: Target specific system configuration files
+Version: 0.1
+Release: 1
+Group: System/Configuration
+BuildArch: noarch
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.bz2
+Source1: %{name}.manifest
+
+Requires(post): systemd
+
+%description
+This package provides target specific system configuration files.
+
+%package u3
+Summary: U3/XU3 specific system configuration files
+Requires: %{name} = %{version}-%{release}
+
+%description u3
+This package provides U3/XU3 specific system configuration files.
+
+%prep
+%setup -q
+
+%build
+cp %{SOURCE1} .
+
+%install
+mkdir -p %{buildroot}%{_unitdir}
+install -m 644 units/resize2fs@.service %{buildroot}%{_unitdir}
+
+# Resize partition for 3-parted target
+mkdir -p %{buildroot}%{_unitdir}/basic.target.wants
+ln -s ../resize2fs@.service %{buildroot}%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\\x2dlabel-system\\x2ddata.service
+ln -s ../resize2fs@.service %{buildroot}%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\\x2dlabel-user.service
+ln -s ../resize2fs@.service %{buildroot}%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\\x2dlabel-rootfs.service
+
+%post
+systemctl daemon-reload
+
+%files
+%manifest %{name}.manifest
+%license LICENSE.Apache-2.0
+%{_unitdir}/resize2fs@.service
+
+%files u3
+%manifest %{name}.manifest
+%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\x2dlabel-system\x2ddata.service
+%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\x2dlabel-user.service
+%{_unitdir}/basic.target.wants/resize2fs@dev-disk-by\x2dlabel-rootfs.service
+