summaryrefslogtreecommitdiff
path: root/packaging/hal-backend-tbm-exynos-tgm.spec
diff options
context:
space:
mode:
authorChangyeon Lee <cyeon.lee@samsung.com>2022-06-22 15:10:01 +0900
committerChangyeon Lee <cyeon.lee@samsung.com>2022-06-22 18:30:18 +0900
commit8fc8a33dffe70104b0c1f1cf3f9511f6a65485a9 (patch)
tree7774b206b327257bd5229f868e898f3bf272bdda /packaging/hal-backend-tbm-exynos-tgm.spec
parentc6dc0907e5499fec44071c1e130224708bc58464 (diff)
downloadlibtbm-exynos-tgm-8fc8a33dffe70104b0c1f1cf3f9511f6a65485a9.tar.gz
libtbm-exynos-tgm-8fc8a33dffe70104b0c1f1cf3f9511f6a65485a9.tar.bz2
libtbm-exynos-tgm-8fc8a33dffe70104b0c1f1cf3f9511f6a65485a9.zip
Change-Id: I4381cf4e4c28706445c0bcdb8b818d3c0b3fcaf9
Diffstat (limited to 'packaging/hal-backend-tbm-exynos-tgm.spec')
-rw-r--r--packaging/hal-backend-tbm-exynos-tgm.spec56
1 files changed, 56 insertions, 0 deletions
diff --git a/packaging/hal-backend-tbm-exynos-tgm.spec b/packaging/hal-backend-tbm-exynos-tgm.spec
new file mode 100644
index 0000000..3a467d9
--- /dev/null
+++ b/packaging/hal-backend-tbm-exynos-tgm.spec
@@ -0,0 +1,56 @@
+Name: hal-backend-tbm-exynos-tgm
+Version: 3.0.3
+Release: 1
+License: MIT
+Summary: hal-backend-tbm module for exynos-tgm
+Group: System/Libraries
+Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
+
+BuildRequires: pkgconfig(libdrm)
+BuildRequires: pkgconfig(libdrm_exynos)
+BuildRequires: pkgconfig(hal-api-common)
+BuildRequires: pkgconfig(hal-api-tbm)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(libudev)
+ExclusiveArch: %{arm} aarch64
+
+%description
+descriptionion: hal tbm backend module for exynos-tgm
+
+%prep
+%setup -q
+cp %{SOURCE1001} .
+
+%build
+
+%reconfigure --prefix=%{_prefix} --libdir=%{_libdir} \
+ --with-hal-libdir=%{_hal_libdir} \
+ --disable-cachectrl \
+ CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
+
+make %{?_smp_mflags}
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+# make rule and license files
+mkdir -p %{buildroot}%{_hal_libdir}/udev/rules.d/
+cp -af rules/99-libhal-backend-tbm-exynos-tgm.rules %{buildroot}%{_hal_libdir}/udev/rules.d/
+mkdir -p %{buildroot}%{_hal_licensedir}/libhal-backend-tbm-exynos-tgm
+cp -af COPYING %{buildroot}%{_hal_licensedir}/libhal-backend-tbm-exynos-tgm
+
+%post
+if [ -f %{_hal_libdir}/libhal_backend_tbm.so ]; then
+ rm -rf %{_hal_libdir}/libhal_backend_tbm.so
+fi
+ln -s libhal-backend-tbm-exynos-tgm.so %{_hal_libdir}/libhal-backend-tbm.so
+
+%postun -p /sbin/ldconfig
+
+%files
+%manifest %{name}.manifest
+%{_hal_licensedir}/libhal-backend-tbm-exynos-tgm/COPYING
+%{_hal_libdir}/libhal-backend-*.so*
+%{_hal_libdir}/udev/rules.d/99-libhal-backend-tbm-exynos-tgm.rules