summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStanislav Vorobiov <s.vorobiov@samsung.com>2013-08-05 19:31:53 +0400
committerStanislav Vorobiov <s.vorobiov@samsung.com>2013-08-09 17:42:20 +0400
commitddaa9c34dbf4119f556fa64b16f7d7b52f0ea530 (patch)
tree199b7899855fe3bdc233e48b6c982435aaedb523 /CMakeLists.txt
parent9ab05f88786e8dd79f7d868c62d286555343941d (diff)
downloademulator-yagl-ddaa9c34dbf4119f556fa64b16f7d7b52f0ea530.tar.gz
emulator-yagl-ddaa9c34dbf4119f556fa64b16f7d7b52f0ea530.tar.bz2
emulator-yagl-ddaa9c34dbf4119f556fa64b16f7d7b52f0ea530.zip
YaGL: wayland platform added
Change-Id: Ife2fa6fde03f956d7753987e7d09deda4cf1bff7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce1b2df..be38025 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,8 @@ endif ()
project(YAGL C)
+set(CMAKE_MODULE_PATH "${YAGL_SOURCE_DIR}/CMake")
+
# USER SETTINGS
if (CMAKE_BUILD_TYPE STREQUAL "")
@@ -88,6 +90,23 @@ if (PLATFORM_GBM)
add_definitions(${GBM_CFLAGS})
include_directories(${GBM_INCLUDE_DIRS})
+
+ pkg_check_modules(LIBUDEV REQUIRED libudev)
+
+ add_definitions(${LIBUDEV_CFLAGS})
+ include_directories(${LIBUDEV_INCLUDE_DIRS})
+endif ()
+
+if (PLATFORM_WAYLAND)
+ pkg_check_modules(WAYLAND_CLIENT REQUIRED wayland-client)
+
+ add_definitions(${WAYLAND_CLIENT_CFLAGS})
+ include_directories(${WAYLAND_CLIENT_INCLUDE_DIRS})
+
+ pkg_check_modules(WAYLAND_SERVER REQUIRED wayland-server)
+
+ add_definitions(${WAYLAND_SERVER_CFLAGS})
+ include_directories(${WAYLAND_SERVER_INCLUDE_DIRS})
endif ()
#fix output directories
@@ -130,6 +149,9 @@ message(STATUS "Install lib dir: " ${INSTALL_LIB_DIR})
if (PLATFORM_GBM)
add_subdirectory(gbm)
endif ()
+if (PLATFORM_WAYLAND)
+add_subdirectory(wayland-egl)
+endif ()
add_subdirectory(EGL)
add_subdirectory(GLESv1_CM)
add_subdirectory(GLESv2)