summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt146
1 files changed, 146 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..3a3281f
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,146 @@
+# Copyright (c) 2011 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+# @file CMakeLists.txt
+# @author Lukasz Wrzosek (l.wrzosek@samsung.com)
+# @version 1.0
+#
+
+SET(TARGET_INSTALLER "wrt-installer")
+
+SET(INSTALLER_SRC_DIR
+ ${PROJECT_SOURCE_DIR}/src
+ )
+
+SET(INSTALLER_CONFIG_PARSER
+ ${INSTALLER_SRC_DIR}/configuration_parser
+ )
+
+SET(INSTALLER_JOBS
+ ${INSTALLER_SRC_DIR}/jobs
+ )
+
+SET(INSTALLER_SECURITY
+ ${INSTALLER_SRC_DIR}/security
+ )
+
+SET(INSTALLER_DEP_CORE_BASE_SOURCE
+ ${INSTALLER_SECURITY}/attribute_facade.cpp
+ ${INSTALLER_SECURITY}/simple_roaming_agent.cpp
+ ${INSTALLER_SECURITY}/security_controller.cpp
+ ${INSTALLER_SECURITY}/security_logic.cpp
+ )
+
+SET(INSTALLER_INCLUDES
+ ${INSTALLER_SRC_DIR}
+ ${INSTALLER_SRC_DIR}/logic
+ ${INSTALLER_SRC_DIR}/jobs
+ ${INSTALLER_SRC_DIR}/jobs/plugin_install
+ ${INSTALLER_SRC_DIR}/jobs/widget_install
+ ${INSTALLER_SRC_DIR}/jobs/widget_uninstall
+ ${INSTALLER_SRC_DIR}/misc
+ ${INSTALLER_SRC_DIR}/configuration_parser
+ ${INSTALLER_SRC_DIR}/wrt-installer
+ ${INSTALLER_SRC_DIR}/security
+ ${INSTALLER_SRC_DIR}/commons
+)
+
+SET(INSTALLER_SOURCES
+ ${INSTALLER_CONFIG_PARSER}/widget_parser.cpp
+ ${INSTALLER_CONFIG_PARSER}/parser_runner.cpp
+ ${INSTALLER_CONFIG_PARSER}/ignoring_parser.cpp
+ ${INSTALLER_CONFIG_PARSER}/deny_all_parser.cpp
+ ${INSTALLER_CONFIG_PARSER}/powder_parser.cpp
+ ${INSTALLER_CONFIG_PARSER}/libiriwrapper.cpp
+ ${INSTALLER_CONFIG_PARSER}/WidgetConfigurationManager.cpp
+ ${INSTALLER_JOBS}/job.cpp
+ ${INSTALLER_JOBS}/plugin_install/job_plugin_install.cpp
+ ${INSTALLER_JOBS}/plugin_install/plugin_install_task.cpp
+ ${INSTALLER_JOBS}/plugin_install/plugin_objects.cpp
+ ${INSTALLER_JOBS}/plugin_install/plugin_metafile_reader.cpp
+ ${INSTALLER_JOBS}/widget_install/job_widget_install.cpp
+ ${INSTALLER_JOBS}/widget_install/task_unzip.cpp
+ ${INSTALLER_JOBS}/widget_install/task_widget_config.cpp
+ ${INSTALLER_JOBS}/widget_install/task_db_update.cpp
+ ${INSTALLER_JOBS}/widget_install/task_smack.cpp
+ ${INSTALLER_JOBS}/widget_install/task_ace_check.cpp
+ ${INSTALLER_JOBS}/widget_install/task_desktop_file.cpp
+ ${INSTALLER_JOBS}/widget_install/task_parental_mode.cpp
+ ${INSTALLER_JOBS}/widget_install/task_certify.cpp
+ ${INSTALLER_JOBS}/widget_install/task_private_storage.cpp
+ ${INSTALLER_JOBS}/widget_install/wac_security.cpp
+ ${INSTALLER_JOBS}/widget_install/widget_update_info.cpp
+ ${INSTALLER_JOBS}/widget_uninstall/job_widget_uninstall.cpp
+ ${INSTALLER_JOBS}/widget_uninstall/task_check.cpp
+ ${INSTALLER_JOBS}/widget_uninstall/task_remove_files.cpp
+ ${INSTALLER_JOBS}/widget_uninstall/task_db_update.cpp
+ ${INSTALLER_JOBS}/widget_uninstall/task_smack.cpp
+ ${INSTALLER_SRC_DIR}/logic/installer_logic.cpp
+ ${INSTALLER_SRC_DIR}/logic/installer_controller.cpp
+ ${INSTALLER_SRC_DIR}/misc/wrt_powder_info_util.cpp
+ ${INSTALLER_SRC_DIR}/misc/wac_widget_id.cpp
+ ${INSTALLER_SRC_DIR}/misc/feature_logic.cpp
+ )
+
+MESSAGE(STATUS "add -DSEP_INSTALLER")
+ADD_DEFINITIONS("-DSEP_INSTALLER")
+
+
+PKG_CHECK_MODULES(INSTALLER_STATIC_DEP
+ libxml-2.0
+ openssl
+ dpl-efl
+ dpl-vcore
+ dpl-event-efl
+ dpl-utils-efl
+ dpl-popup-efl
+ dpl-wrt-dao-ro
+ dpl-wrt-dao-rw
+ dpl-ace
+ dpl-ace-dao-ro
+ dpl-ace-dao-rw
+ ecore-x
+ elm-webview
+ xmlsec1
+ libidn
+ libiri
+ libpcrecpp
+ REQUIRED
+ )
+
+INCLUDE_DIRECTORIES(
+ ${INSTALLER_DEP_INCLUDES}
+ ${INSTALLER_INCLUDES}
+ ${INSTALLER_STATIC_DEP_INCLUDE_DIRS}
+ )
+
+ADD_LIBRARY(${TARGET_INSTALLER_STATIC} STATIC
+ ${INSTALLER_DEP_CORE_BASE_SOURCE}
+ ${INSTALLER_SOURCES}
+ )
+
+ADD_DEFINITIONS(${INSTALLER_STATIC_DEP_CFLAGS})
+ADD_DEFINITIONS(${INSTALLER_STATIC_DEP_CFLAGS_OTHERS})
+
+TARGET_LINK_LIBRARIES(${TARGET_INSTALLER_STATIC}
+ ${INSTALLER_STATIC_DEP_LIBRARIES}
+ )
+
+SET_TARGET_PROPERTIES(${TARGET_INSTALLER_STATIC} PROPERTIES
+ COMPILE_FLAGS -fPIC)
+
+ADD_SUBDIRECTORY(pkg-manager)
+ADD_SUBDIRECTORY(wrt-installer)
+ADD_SUBDIRECTORY(config_generator)