summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/compat1
-rw-r--r--debian/control21
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rw-r--r--debian/libpcre-dev.install.in4
-rw-r--r--debian/libpcre.install.in3
-rwxr-xr-xdebian/rules125
8 files changed, 164 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ef080b0
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,8 @@
+pcre (7.6-3-3slp2) unstable; urgency=low
+
+ * Init changelog
+
+ * Git : pkgs/p/pcre
+ * Tag : pcre_7.6-3-3slp2
+
+ -- Yunchan Cho <yunchan.cho@samsung.com> Mon, 29 Nov 2010 13:54:22 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..89f102a
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: pcre
+Section: devel
+Priority: extra
+Maintainer: Andrew Lee <hyunchul2.lee@samsung.com>, Piotr Fatiga <p.fatyga@samsung.com>
+Uploaders: Koeun Choi <koeun.choi@samsung.com>, Ming Jin <ming79.jin@samsung.com>, Yunchan Cho <yunchan.cho@samsung.com>
+Build-Depends: debhelper (>= 5), autotools-dev
+Standards-Version: 3.7.2
+
+Package: libpcre
+Architecture: any
+Section: libs
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: pcre
+Description: regular expression library - runtime library
+
+Package: libpcre-dev
+Architecture: any
+Section: libs
+Depends: libpcre (= ${Source-Version})
+Replaces: pcre-dev
+Description: regular expression dev library - runtime library
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/libpcre-dev.install.in b/debian/libpcre-dev.install.in
new file mode 100644
index 0000000..3f83920
--- /dev/null
+++ b/debian/libpcre-dev.install.in
@@ -0,0 +1,4 @@
+@PREFIX@/include/*
+@PREFIX@/lib/*.la
+@PREFIX@/lib/*.a
+@PREFIX@/lib/pkgconfig/*.pc
diff --git a/debian/libpcre.install.in b/debian/libpcre.install.in
new file mode 100644
index 0000000..19a26d5
--- /dev/null
+++ b/debian/libpcre.install.in
@@ -0,0 +1,3 @@
+@PREFIX@/bin/*
+@PREFIX@/lib/*.so*
+@PREFIX@/share/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f12218c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,125 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DATADIR ?= /opt
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+config.status:
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" ./autogen.sh --prefix=$(PREFIX)
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+# mkdir -p autotools
+# libtoolize --force || exit 1
+# aclocal -I autotools || exit 1
+# autoheader || exit 1
+# automake --add-missing --copy || exit 1
+# autoconf || exit 1
+
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/ncurses.sgml > ncurses.1
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) distclean
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/ncurses.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install