summaryrefslogtreecommitdiff
path: root/xmodmap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xmodmap/Makefile.am')
-rw-r--r--xmodmap/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/xmodmap/Makefile.am b/xmodmap/Makefile.am
new file mode 100644
index 0000000..527ee27
--- /dev/null
+++ b/xmodmap/Makefile.am
@@ -0,0 +1,58 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+SUBDIRS=man
+bin_PROGRAMS = xmodmap
+
+AM_CFLAGS = $(CWARNFLAGS) $(XMODMAP_CFLAGS)
+xmodmap_LDADD = $(XMODMAP_LIBS)
+
+xmodmap_SOURCES = \
+ exec.c \
+ handle.c \
+ pf.c \
+ wq.h \
+ xmodmap.c \
+ xmodmap.h
+
+EXTRA_DIST = \
+ autogen.sh \
+ swap.km
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(AM_CFLAGS) $(xmodmap_SOURCES)
+endif LINT