summaryrefslogtreecommitdiff
path: root/packaging/e17-mod-tizen-pm-helper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/e17-mod-tizen-pm-helper.spec')
-rwxr-xr-xpackaging/e17-mod-tizen-pm-helper.spec67
1 files changed, 67 insertions, 0 deletions
diff --git a/packaging/e17-mod-tizen-pm-helper.spec b/packaging/e17-mod-tizen-pm-helper.spec
new file mode 100755
index 0000000..d9909d5
--- /dev/null
+++ b/packaging/e17-mod-tizen-pm-helper.spec
@@ -0,0 +1,67 @@
+Name: e17-mod-tizen-pm-helper
+Summary: The E17 pm-helper for Tizen
+Version: 0.1.1
+Release: 1
+Group: System/GUI/Other
+License: BSD 2-clause
+Source0: %{name}-%{version}.tar.gz
+BuildRequires: pkgconfig(enlightenment)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(ttrace)
+
+%description
+The E17 Extra Modules The E17 extra modules consists of modules made by Tizen.
+
+%prep
+%setup -q
+
+
+%build
+
+export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
+export CFLAGS+=" -Wall -g -fPIC -rdynamic -Werror-implicit-function-declaration ${GC_SECTIONS_FLAGS} "
+export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
+
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+
+%if "%{?tizen_profile_name}" == "mobile"
+export CFLAGS+=" -D_ENV_MOBILE_"
+%else
+%if "%{?tizen_profile_name}" == "wearable"
+export CFLAGS+=" -D_ENV_WEARABLE_"
+%endif
+%endif
+
+%ifarch %{arm}
+export CFLAGS+=" -D_ENV_ARM"
+%endif
+
+%autogen
+%configure --prefix=/usr
+make %{?jobs:-j%jobs}
+cd -
+
+%install
+rm -rf %{buildroot}
+
+# for smack rule
+mkdir -p %{buildroot}/etc/smack/accesses.d
+cp %{_builddir}/%{buildsubdir}/e17-mod-tizen-pm-helper.efl %{buildroot}/etc/smack/accesses.d
+
+# for license notification
+mkdir -p %{buildroot}/usr/share/license
+cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
+
+
+make install DESTDIR=%{buildroot}
+
+find %{buildroot}/usr/lib/enlightenment/modules/ -name *.la | xargs rm
+find %{buildroot}/usr/lib/enlightenment/modules/ -name *.a | xargs rm
+
+%files
+%manifest e17-mod-tizen-pm-helper.manifest
+%defattr(-,root,root,-)
+%{_libdir}/enlightenment/modules/e17-mod-tizen-pm-helper
+/usr/share/license/%{name}
+/etc/smack/accesses.d/e17-mod-tizen-pm-helper.efl
+