summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog31
-rwxr-xr-xdebian/control23
-rw-r--r--debian/postinst1
-rwxr-xr-xdebian/rules102
4 files changed, 157 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..52b9339
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,31 @@
+oma-dm-agent (0.1.4) unstable; urgency=low
+
+ * 1. Prevent defects fixed, license file update.
+ * Git: framework/system/oma-dm-agent
+ * Tag: oma-dm-agent_0.1.4
+
+ -- Juhaki Park <juhaki.park@samsung.com> Mon, 21 Jan 2012 22:03:02 +0900
+
+oma-dm-agent (0.1.3) unstable; urgency=low
+
+ * 1. Prevent defects fixed.
+ * Git: framework/system/oma-dm-agent
+ * Tag: oma-dm-agent_0.1.3
+
+ -- Juhaki Park <juhaki.park@samsung.com> Wed, 09 Jan 2012 18:14:02 +0900
+
+oma-dm-agent (0.1.2) unstable; urgency=low
+
+ * 1. Internal: build error & dependency patch
+ * Git: framework/system/oma-dm-agent
+ * Tag: oma-dm-agent_0.1.2
+
+ -- WooJin Yun <suhoangel9@samsung.com> Fri, 28 Dec 2012 22:54:02 +0900
+
+oma-dm-agent (0.1.1) unstable; urgency=low
+
+ * Initial update
+ * Git: framework/system/oma-dm-agent
+ * Tag: oma-dm-agent_0.1.1
+
+ -- WooJin Yun <suhoangel9@samsung.com> Wed, 01 Feb 2012 21:16:27 +0900
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..9e6c785
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,23 @@
+Source: oma-dm-agent
+Section: embedded
+Priority: optional
+Maintainer: WooJin Yun <suhoangel9@samsung.com>, Joohark Park <juhaki.park@samsung.com>, Junhyuk Lee <junhyuk7.lee@samsung.com>
+Uploaders: Joohark Park <juhaki.park@samsung.com>, Junhyuk Lee <junhyuk7.lee@samsung.com>
+Build-Depends: debhelper (>= 5), libglib2.0-dev, libsoup2.4-dev, libsqlite3-dev, check, libexpat1-dev, libxml2-dev, libaul-1-dev, libwbxml2-dev, libsync-agent-framework-dev, liboauth-dev, libappsvc-dev
+Standards-Version: 0.1.1
+
+
+Package: oma-dm-agent
+Section: embedded
+Architecture: any
+Priority: optional
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: oma-dm-agent pkg
+
+Package: oma-dm-agent-dbg
+Section: embedded
+Architecture: any
+Priority: optional
+Depends: ${misc:Depends} oma-dm-agent (= ${Source-Version})
+Description: oma-dm-agent pkg (dbg)
+
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..1a24852
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d456192
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,102 @@
+#!/usr/bin/make -f
+
+## DO NOT MODIFY THIS AREA : BEGIN
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# $(PKGDIR) is a package build directory to create a final .deb package .
+#include debian/control.slp
+
+PKGDIR = debian/PKG
+ifneq (,$(filter ide,$(DEB_BUILD_OPTIONS)))
+DESTDIR = .
+else
+DESTDIR = ..
+endif
+CONTROLFILE = debian/control.slp
+CONTROLFILE_SRC = debian/control
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+build: pre-build configure
+ # Add here commands to compile the package.
+ $(MAKE)
+
+configure:
+ cmake . -DCMAKE_INSTALL_PREFIX=${AppInstallPath} -DCMAKE_PROJECT=${Source}
+ rm -rf CMakeFiles/CompilerIdC*
+# sed 's/^Package:.*$$/Package: $(Package)/' $(CONTROLFILE_SRC) > $(CONTROLFILE_SRC).tmp ; mv -f $(CONTROLFILE_SRC).tmp $(CONTROLFILE_SRC)
+
+clean:
+ # Add here commands to clean up before the build process.
+ # debian clean
+ -$(MAKE) clean
+
+ -find . -name "CMakeFiles" -exec rm -rf {} \;
+ -find . -name "CMakeCache.txt" -exec rm -rf {} \;
+ -find . -name "Makefile" -exec rm -rf {} \;
+ -find . -name "cmake_install.cmake" -exec rm -rf {} \;
+ -find . -name "install_manifest.txt" -exec rm -rf {} \;
+ -find . -name "*.pc" -exec rm -rf {} \;
+ -find . -name "*.so" -exec rm -rf {} \;
+
+ -rm -rf $(PKGDIR)
+
+ dh_clean
+
+install: build pre-install
+ rm -rf $(PKGDIR)
+ mkdir $(PKGDIR)
+
+ # Add here commands to install the package into $(PKGDIR).
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/init.d
+ install -c $(CURDIR)/syncmldm_mgr $(CURDIR)/debian/tmp/etc/rc.d/init.d
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc3.d
+ ln -s ../init.d/syncmldm_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/S91oma-dm-agent
+
+ mkdir -p $(CURDIR)/debian/tmp/etc/rc.d/rc5.d
+ ln -s ../init.d/syncmldm_mgr $(CURDIR)/debian/tmp/etc/rc.d/rc5.d/S91oma-dm-agent
+
+# Build architecture-dependent files here.
+binary: install pre-binary
+ dh_testdir
+ dh_testroot
+ #dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+ dh_link
+ dh_strip --dbg-package=oma-dm-agent
+ dh_compress
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: build clean install binary
+## DO NOT MODIFY THIS AREA : END
+
+## DO NOT MODIFY OR DELETE TARGET.
+pre-build:
+ # Add here commands to execute before the build process.
+
+pre-install:
+ # Add here commands to execute before installing the binaries into $(PKGDIR).
+
+pre-binary:
+ # Add here commands to execute before creating a package.
+
+