summaryrefslogtreecommitdiff
path: root/packaging/haptic-module-tizen.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/haptic-module-tizen.spec')
-rw-r--r--packaging/haptic-module-tizen.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/packaging/haptic-module-tizen.spec b/packaging/haptic-module-tizen.spec
new file mode 100644
index 0000000..db4d6bc
--- /dev/null
+++ b/packaging/haptic-module-tizen.spec
@@ -0,0 +1,46 @@
+#sbs-git:slp/pkgs/d/devman devman 0.1.6 5bf2e95e0bb15c43ff928f7375e1978b0accb0f8
+Name: haptic-module-tizen
+Summary: Haptic Module library
+Version: 0.1.0
+Release: 9
+Group: System/Libraries
+License: APLv2
+Source0: %{name}-%{version}.tar.gz
+BuildRequires: cmake
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(haptic-plugin)
+BuildRequires: pkgconfig(device-node)
+
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description
+
+%prep
+%setup -q
+
+%build
+%if 0%{?simulator}
+%cmake . -DSIMULATOR=yes
+%else
+%ifarch %{ix86}
+CFLAGS=`echo %{optflags} |sed 's/\-fexceptions//g'`
+%endif
+%cmake . -DSIMULATOR=no
+%endif
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf %{buildroot}
+%make_install
+mkdir -p %{buildroot}%{_datadir}/license
+cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files
+%{_libdir}/libhaptic-module.so
+%{_datadir}/license/%{name}