summaryrefslogtreecommitdiff
path: root/ext/lame/Makefile.am
diff options
context:
space:
mode:
authorjk7744.park <jk7744.park@samsung.com>2015-10-24 16:49:49 +0900
committerjk7744.park <jk7744.park@samsung.com>2015-10-24 16:49:49 +0900
commitfed9ccc4d4585e39e42dc6079432ff6aae32eb1a (patch)
tree6731ed9fe52be60184497e20ece1a9b725f8d8b9 /ext/lame/Makefile.am
parentb324cb9340d425326f3d0a491c7754cfcdd1c571 (diff)
downloadgst-plugins-ugly-accepted/tizen_2.4_mobile.tar.gz
gst-plugins-ugly-accepted/tizen_2.4_mobile.tar.bz2
gst-plugins-ugly-accepted/tizen_2.4_mobile.zip
Diffstat (limited to 'ext/lame/Makefile.am')
-rw-r--r--ext/lame/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ext/lame/Makefile.am b/ext/lame/Makefile.am
new file mode 100644
index 0000000..c7124dd
--- /dev/null
+++ b/ext/lame/Makefile.am
@@ -0,0 +1,11 @@
+plugin_LTLIBRARIES = libgstlame.la
+
+libgstlame_la_SOURCES = gstlamemp3enc.c plugin.c
+libgstlame_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(LAME_CFLAGS)
+libgstlame_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(LAME_LIBS)
+libgstlame_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstlame_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+
+noinst_HEADERS = gstlamemp3enc.h