summaryrefslogtreecommitdiff
path: root/gst/flx/Makefile.am
diff options
context:
space:
mode:
authorjk7744.park <jk7744.park@samsung.com>2015-02-01 13:44:31 +0900
committerjk7744.park <jk7744.park@samsung.com>2015-02-01 13:44:31 +0900
commit73ea2d7db1c622705a034dc3aa73b02693bc9aad (patch)
tree8ec6ded7aa6ffd57bc2b0c1a44d70dc1d46d4be3 /gst/flx/Makefile.am
parent9e1f49bdfcf5a218296206db6db790187c114084 (diff)
downloadgst-plugins-good0.10-tizen_2.3.tar.gz
gst-plugins-good0.10-tizen_2.3.tar.bz2
gst-plugins-good0.10-tizen_2.3.zip
Diffstat (limited to 'gst/flx/Makefile.am')
-rw-r--r--gst/flx/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/gst/flx/Makefile.am b/gst/flx/Makefile.am
new file mode 100644
index 0000000..01d8bd8
--- /dev/null
+++ b/gst/flx/Makefile.am
@@ -0,0 +1,24 @@
+plugin_LTLIBRARIES = libgstflxdec.la
+
+libgstflxdec_la_SOURCES = gstflxdec.c flx_color.c
+libgstflxdec_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstflxdec_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
+libgstflxdec_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstflxdec_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = flx_fmt.h flx_color.h gstflxdec.h
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstflxdec -:SHARED libgstflxdec \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstflxdec_la_SOURCES) \
+ $(nodist_libgstflxdec_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstflxdec_la_CFLAGS) \
+ -:LDFLAGS $(libgstflxdec_la_LDFLAGS) \
+ $(libgstflxdec_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@