summaryrefslogtreecommitdiff
path: root/sys/osxvideo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/osxvideo/Makefile.am')
-rwxr-xr-xsys/osxvideo/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys/osxvideo/Makefile.am b/sys/osxvideo/Makefile.am
new file mode 100755
index 0000000..e908695
--- /dev/null
+++ b/sys/osxvideo/Makefile.am
@@ -0,0 +1,18 @@
+
+plugin_LTLIBRARIES = libgstosxvideosink.la
+
+libgstosxvideosink_la_SOURCES = osxvideosink.m cocoawindow.m
+libgstosxvideosink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstosxvideosink_la_OBJCFLAGS = $(GST_OBJCFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstosxvideosink_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_BASE_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_API_VERSION)
+
+libgstosxvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,QuickTime -Wl,-framework -Wl,OpenGL
+libgstosxvideosink_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS) --tag=CC
+
+noinst_HEADERS = osxvideosink.h cocoawindow.h