summaryrefslogtreecommitdiff
path: root/gst/videobox/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/videobox/Makefile.am')
-rw-r--r--gst/videobox/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/gst/videobox/Makefile.am b/gst/videobox/Makefile.am
new file mode 100644
index 0000000..32e1c5d
--- /dev/null
+++ b/gst/videobox/Makefile.am
@@ -0,0 +1,36 @@
+plugin_LTLIBRARIES = libgstvideobox.la
+
+ORC_SOURCE=gstvideoboxorc
+include $(top_srcdir)/common/orc.mak
+
+libgstvideobox_la_SOURCES = gstvideobox.c
+nodist_libgstvideobox_la_SOURCES = $(ORC_NODIST_SOURCES)
+libgstvideobox_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(ORC_CFLAGS)
+libgstvideobox_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(ORC_LIBS) \
+ -lgstvideo-@GST_API_VERSION@
+libgstvideobox_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstvideobox_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+
+noinst_HEADERS = gstvideobox.h
+EXTRA_DIST += README
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstvideobox -:SHARED libgstvideobox \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstvideobox_la_SOURCES) \
+ $(nodist_libgstvideobox_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstvideobox_la_CFLAGS) \
+ -:LDFLAGS $(libgstvideobox_la_LDFLAGS) \
+ $(libgstvideobox_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@