summaryrefslogtreecommitdiff
path: root/ext/pulse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/pulse/Makefile.am')
-rwxr-xr-xext/pulse/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ext/pulse/Makefile.am b/ext/pulse/Makefile.am
new file mode 100755
index 0000000..f86688d
--- /dev/null
+++ b/ext/pulse/Makefile.am
@@ -0,0 +1,28 @@
+plugin_LTLIBRARIES = libgstpulse.la
+
+libgstpulse_la_SOURCES = \
+ plugin.c \
+ pulsesink.c \
+ pulsesrc.c \
+ pulsedeviceprovider.c \
+ pulseutil.c
+
+libgstpulse_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(PULSE_CFLAGS)
+libgstpulse_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) \
+ -lgstpbutils-$(GST_API_VERSION) \
+ $(INIPARSER_LIBS) \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(PULSE_LIBS)
+libgstpulse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstpulse_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+
+if PCM_DUMP_ENABLE
+libgstpulse_la_CFLAGS += $(VCONF_CFLAGS) -DPCM_DUMP_ENABLE
+libgstpulse_la_LIBADD += $(VCONF_LIBS)
+endif
+
+noinst_HEADERS = \
+ pulsesink.h \
+ pulsesrc.h \
+ pulsedeviceprovider.h \
+ pulseutil.h
+