summaryrefslogtreecommitdiff
path: root/ext/dv/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dv/Makefile.am')
-rw-r--r--ext/dv/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/ext/dv/Makefile.am b/ext/dv/Makefile.am
new file mode 100644
index 0000000..113f33b
--- /dev/null
+++ b/ext/dv/Makefile.am
@@ -0,0 +1,20 @@
+plugin_LTLIBRARIES = libgstdv.la
+
+libgstdv_la_SOURCES = gstdv.c gstdvdec.c gstdvdemux.c gstsmptetimecode.c
+libgstdv_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(LIBDV_CFLAGS)
+libgstdv_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) -lgstvideo-$(GST_API_VERSION) \
+ $(GST_BASE_LIBS) $(GST_LIBS) $(LIBDV_LIBS)
+libgstdv_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstdv_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+
+noinst_HEADERS = gstdvdemux.h gstdvdec.h gstsmptetimecode.h
+
+EXTRA_DIST = NOTES
+
+noinst_PROGRAMS = smpte_test
+
+smpte_test_SOURCES = smpte_test.c gstsmptetimecode.c
+smpte_test_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(LIBDV_CFLAGS)
+smpte_test_LDADD = $(GST_BASE_LIBS) $(GST_LIBS)
+