summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/Makefile.am')
-rwxr-xr-xdocs/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100755
index 0000000..8ff41fe
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,19 @@
+if ENABLE_GTK_DOC
+if ENABLE_PLUGIN_DOCS
+PLUGIN_DOCS_DIRS = plugins
+else
+PLUGIN_DOCS_DIRS =
+endif
+else
+PLUGIN_DOCS_DIRS = plugins
+endif
+
+SUBDIRS = $(PLUGIN_DOCS_DIRS)
+DIST_SUBDIRS = plugins
+
+EXTRA_DIST = \
+ random/ChangeLog-0.8 \
+ version.entities.in
+
+upload:
+ @if test "x$(SUBDIRS)" != x; then for a in $(SUBDIRS); do cd $$a; make upload; cd ..; done; fi