summaryrefslogtreecommitdiff
path: root/packaging/maps-plugin-mapquest.spec
diff options
context:
space:
mode:
authorjk7744.park <jk7744.park@samsung.com>2015-10-24 16:45:49 +0900
committerjk7744.park <jk7744.park@samsung.com>2015-10-24 16:45:49 +0900
commit6c7cebf382b34d1e32b260e6c93556f68a0bbaec (patch)
treea1113bcbe08e94f2d64881158ec03de6aac1cb34 /packaging/maps-plugin-mapquest.spec
parent698b4074c441d1bdfc2dd7f1610a5402acb06654 (diff)
downloadmaps-plugin-mapquest-accepted/tizen_2.4_mobile.tar.gz
maps-plugin-mapquest-accepted/tizen_2.4_mobile.tar.bz2
maps-plugin-mapquest-accepted/tizen_2.4_mobile.zip
Diffstat (limited to 'packaging/maps-plugin-mapquest.spec')
-rw-r--r--packaging/maps-plugin-mapquest.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/packaging/maps-plugin-mapquest.spec b/packaging/maps-plugin-mapquest.spec
new file mode 100644
index 0000000..fafafe9
--- /dev/null
+++ b/packaging/maps-plugin-mapquest.spec
@@ -0,0 +1,95 @@
+Name: maps-plugin-mapquest
+Summary: Tizen MapQuest Maps Plug-in Library
+Version: 0.0.3
+Release: 1
+Group: Location/Libraries
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
+
+#Requires(post): eglibc
+#Requires(postun): eglibc
+
+BuildRequires: cmake
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gmodule-2.0)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(libcurl)
+BuildRequires: pkgconfig(capi-network-connection)
+BuildRequires: pkgconfig(capi-maps-service)
+BuildRequires: capi-maps-service-plugin-devel
+BuildRequires: pkgconfig(json-glib-1.0)
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%ifarch %{arm}
+%define ARCH arm
+%else
+%define ARCH i586
+%endif
+
+%description
+This packages provides Plugin APIs capsulating MapQuest Maps Open APIs for Maps Service Library.
+
+%prep
+%setup -q
+
+%build
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE -g"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE -g"
+export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
+%endif
+
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version}
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
+
+%post
+/sbin/ldconfig
+
+%postun
+/sbin/ldconfig
+
+%files
+%manifest capi-maps-plugin-mapquest.manifest
+%defattr(-,root,root,-)
+%{_libdir}/maps/plugins/libmaps-plugin-mapquest.so
+%{_libdir}/maps/plugins/libmaps-plugin-mapquest.so.*
+%{_libdir}/pkgconfig/maps-plugin-mapquest.pc
+/usr/share/license/maps-plugin-mapquest
+
+%package devel
+Summary: Tizen MapsQuest Maps Plug-in Library (Development)
+Group: Framework/maps
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+This packages provides Plugin APIs capsulating MapQuest Maps Open APIs for Maps Service Library. (Development)
+
+%post devel
+/sbin/ldconfig
+
+%postun devel
+/sbin/ldconfig
+
+%files devel
+%defattr(-,root,root,-)
+%{_includedir}/mapquest-plugin/*.h
+%{_libdir}/pkgconfig/maps-plugin-mapquest.pc
+%{_libdir}/maps/plugins/libmaps-plugin-mapquest.so
+
+%package test
+Summary: Tizen MapQuest Maps Plug-in Library (Internal Dev)
+Group: Framework/maps
+Requires: capi-maps-service = %{version}-%{release}
+
+%description test
+This packages provides Plugin APIs capsulating MapQuest Maps Open APIs for Maps Service Library. (Internal Dev)
+