summaryrefslogtreecommitdiff
path: root/packaging/maps-plugin-here.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/maps-plugin-here.spec')
-rwxr-xr-xpackaging/maps-plugin-here.spec29
1 files changed, 27 insertions, 2 deletions
diff --git a/packaging/maps-plugin-here.spec b/packaging/maps-plugin-here.spec
index 45e07fe..3da1b69 100755
--- a/packaging/maps-plugin-here.spec
+++ b/packaging/maps-plugin-here.spec
@@ -1,7 +1,7 @@
Name: maps-plugin-here
Summary: Tizen HERE Maps Plug-in Library
-Version: 0.1.4
-Release: 1
+Version: 0.1.7
+Release: 2
Group: Location/Libraries
License: Apache-2.0
Source0: %{name}-%{version}.tar.gz
@@ -9,12 +9,23 @@ Source0: %{name}-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(gmodule-2.0)
+BuildRequires: pkgconfig(libxml-2.0)
BuildRequires: pkgconfig(dlog)
BuildRequires: pkgconfig(capi-maps-service)
BuildRequires: capi-maps-service-plugin-devel
BuildRequires: pkgconfig(heremaps-engine)
BuildRequires: pkgconfig(capi-network-connection)
BuildRequires: pkgconfig(capi-appfw-app-manager)
+BuildRequires: pkgconfig(capi-appfw-application)
+BuildRequires: pkgconfig(capi-system-info)
+BuildRequires: pkgconfig(efl-extension)
+BuildRequires: pkgconfig(elementary)
+BuildRequires: pkgconfig(vconf)
+BuildRequires: pkgconfig(appcore-efl)
+BuildRequires: pkgconfig(ecore)
+BuildRequires: pkgconfig(evas)
+BuildRequires: gettext-tools
+
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
@@ -53,3 +64,17 @@ cp LICENSE %{buildroot}/usr/share/license/%{name}
%defattr(-,root,root,-)
%{_libdir}/maps/plugins/libmaps-plugin-here.so*
/usr/share/license/maps-plugin-here
+
+%package -n org.tizen.heremaps-uc
+Summary: HereMaps UC popup
+Requires: %{name} = %{version}-%{release}
+
+%description -n org.tizen.heremaps-uc
+HereMaps UC popup
+
+%files -n org.tizen.heremaps-uc
+%manifest heremaps-uc/org.tizen.heremaps-uc.manifest
+%defattr(-,root,root,-)
+/usr/apps/org.tizen.heremaps-uc/bin/*
+/usr/apps/org.tizen.heremaps-uc/res/locale
+/usr/share/packages/org.tizen.heremaps-uc.xml