summaryrefslogtreecommitdiff
path: root/packaging/maps-plugin-here.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/maps-plugin-here.spec')
-rwxr-xr-xpackaging/maps-plugin-here.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/packaging/maps-plugin-here.spec b/packaging/maps-plugin-here.spec
new file mode 100755
index 0000000..45e07fe
--- /dev/null
+++ b/packaging/maps-plugin-here.spec
@@ -0,0 +1,55 @@
+Name: maps-plugin-here
+Summary: Tizen HERE Maps Plug-in Library
+Version: 0.1.4
+Release: 1
+Group: Location/Libraries
+License: Apache-2.0
+Source0: %{name}-%{version}.tar.gz
+
+BuildRequires: cmake
+BuildRequires: pkgconfig(glib-2.0)
+BuildRequires: pkgconfig(gmodule-2.0)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(capi-maps-service)
+BuildRequires: capi-maps-service-plugin-devel
+BuildRequires: pkgconfig(heremaps-engine)
+BuildRequires: pkgconfig(capi-network-connection)
+BuildRequires: pkgconfig(capi-appfw-app-manager)
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description
+This packages provides Plugin APIs capsulating HERE Maps Engine Library for Maps Service Library.
+
+%prep
+%setup -q
+
+%build
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE -g"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE -g"
+export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
+%endif
+
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version} -DLIBDIR=%{_libdir}
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf %{buildroot}
+%make_install
+
+mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
+
+%post
+/sbin/ldconfig
+
+%postun
+/sbin/ldconfig
+
+%files
+%manifest maps-plugin-here.manifest
+%defattr(-,root,root,-)
+%{_libdir}/maps/plugins/libmaps-plugin-here.so*
+/usr/share/license/maps-plugin-here