summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README0
-rw-r--r--debian/capi-system-media-key-dev.install4
-rw-r--r--debian/capi-system-media-key-dev.postinst1
-rw-r--r--debian/capi-system-media-key.install1
-rw-r--r--debian/capi-system-media-key.postinst1
-rwxr-xr-xdebian/changelog9
-rw-r--r--debian/compat1
-rwxr-xr-xdebian/control22
-rwxr-xr-xdebian/rules68
9 files changed, 107 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/README
diff --git a/debian/capi-system-media-key-dev.install b/debian/capi-system-media-key-dev.install
new file mode 100644
index 0000000..761a28b
--- /dev/null
+++ b/debian/capi-system-media-key-dev.install
@@ -0,0 +1,4 @@
+/usr/include/*
+/usr/include/*/*
+/usr/lib/pkgconfig/*.pc
+
diff --git a/debian/capi-system-media-key-dev.postinst b/debian/capi-system-media-key-dev.postinst
new file mode 100644
index 0000000..1a24852
--- /dev/null
+++ b/debian/capi-system-media-key-dev.postinst
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/debian/capi-system-media-key.install b/debian/capi-system-media-key.install
new file mode 100644
index 0000000..4a755a4
--- /dev/null
+++ b/debian/capi-system-media-key.install
@@ -0,0 +1 @@
+/usr/lib/lib*.so*
diff --git a/debian/capi-system-media-key.postinst b/debian/capi-system-media-key.postinst
new file mode 100644
index 0000000..1a24852
--- /dev/null
+++ b/debian/capi-system-media-key.postinst
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/debian/changelog b/debian/changelog
new file mode 100755
index 0000000..5b19b3f
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+capi-system-media-key (0.0.1-1) unstable; urgency=low
+
+ * Initial upload
+ * Git: slp/api/media-key
+ * Tag: capi-system-media-key_0.0.1-1
+
+
+ -- Jaeho Lee <jaeho81.lee@samsung.com> Sat, 28 Aug 2012 10:40:37 +0900
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..cca9785
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+
+Source: capi-system-media-key
+Section: libs
+Priority: extra
+Maintainer: Jaeho Lee <jaeho81.lee@samsung.com>
+Build-Depends: debhelper (>= 5), dlog-dev, capi-base-common-dev, libaul-1-dev, libslp-utilx-dev
+
+Package: capi-system-media-key
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: A Media key library in Tizen Native API
+
+Package: capi-system-media-key-dev
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, capi-system-media-key (= ${Source-Version}), capi-base-common-dev
+Description: A Media key library in Tizen Native API (DEV)
+
+Package: capi-system-media-key-dbg
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, capi-system-media-key (= ${Source-Version})
+Description: A Media key library in Tizen Native API (DBG)
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1af2fa7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,68 @@
+#!/usr/bin/make -f
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+CMAKE_ROOT_DIR ?= $(CURDIR)
+CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+
+FULLVER ?= $(shell dpkg-parsechangelog | grep Version: | cut -d ' ' -f 2 | cut -d '-' -f 1)
+MAJORVER ?= $(shell echo $(FULLVER) | cut -d '.' -f 1)
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake .. -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
+ touch configure-stamp
+
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ cd $(CMAKE_BUILD_DIR) && $(MAKE)
+ touch $@
+
+clean:
+ cd $(CMAKE_ROOT_DIR)
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ rm -f `find . -name *.pc`
+ rm -rf $(CMAKE_BUILD_DIR)
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+binary-indep: build install
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+ dh_installman
+ dh_link
+ dh_strip --dbg-package=capi-system-media-key-dbg
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
+