summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJonghoon Lim <j.h.lim@samsung.com>2012-02-16 17:17:02 +0900
committerJonghoon Lim <j.h.lim@samsung.com>2012-02-16 17:17:02 +0900
commit2242f530bc8c60ba203d3157346c236e77384331 (patch)
tree27cf7c2514fd10a36b3495220181d0be46b907d0 /debian
parent83807e88f73bb7d580a874caf29172128f763d2e (diff)
downloadcontacts-2242f530bc8c60ba203d3157346c236e77384331.tar.gz
contacts-2242f530bc8c60ba203d3157346c236e77384331.tar.bz2
contacts-2242f530bc8c60ba203d3157346c236e77384331.zip
versioning updated
Diffstat (limited to 'debian')
-rwxr-xr-x[-rw-r--r--]debian/changelog4
-rwxr-xr-xdebian/rules4
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index abe040a..3eb0dde 100644..100755
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,8 @@
-capi-social-contacts (0.1.1-25) unstable; urgency=low
+capi-social-contacts (0.1.1-28) unstable; urgency=low
* Multiple address books feature added
* Git: api/contacts
- * Tag: capi-social-contacts_0.1.1-25
+ * Tag: capi-social-contacts_0.1.1-28
-- Jonghoon Lim <j.h.lim@samsung.com> Fri, 10 Feb 2012 15:12:20 +0900
diff --git a/debian/rules b/debian/rules
index af730d0..7312770 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+FULLVER ?= $(shell dpkg-parsechangelog | grep Version: | cut -d ' ' -f 2 | cut -d '-' -f 1)
+MAJORVER ?= $(shell echo $(FULLVER) | cut -d '.' -f 1)
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -13,7 +15,7 @@ CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
configure: configure-stamp
configure-stamp:
dh_testdir
- mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake ..
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake .. -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
touch configure-stamp