summaryrefslogtreecommitdiff
path: root/lib/dpkg/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/dpkg/test/Makefile.am')
-rw-r--r--lib/dpkg/test/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/dpkg/test/Makefile.am b/lib/dpkg/test/Makefile.am
new file mode 100644
index 0000000..54fbd15
--- /dev/null
+++ b/lib/dpkg/test/Makefile.am
@@ -0,0 +1,35 @@
+## Process this file with automake to produce Makefile.in
+
+AM_CPPFLAGS = \
+ -DADMINDIR=\"$(admindir)\" \
+ -idirafter $(top_srcdir)/lib/compat \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/lib
+LDADD = \
+ $(top_builddir)/lib/dpkg/libdpkg.a \
+ $(top_builddir)/lib/compat/libcompat.a \
+ $(LIBINTL)
+
+
+# The tests are sorted in order of increasing complexity.
+check_PROGRAMS = \
+ t-test \
+ t-macros \
+ t-string \
+ t-buffer \
+ t-path \
+ t-progname \
+ t-subproc \
+ t-command \
+ t-varbuf \
+ t-ar \
+ t-deb-version \
+ t-arch \
+ t-version \
+ t-pkginfo \
+ t-pkg-list \
+ t-pkg-queue \
+ t-trigger \
+ t-mod-db
+
+TESTS = $(check_PROGRAMS)