summaryrefslogtreecommitdiff
path: root/dpkg-deb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dpkg-deb/Makefile.am')
-rw-r--r--dpkg-deb/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/dpkg-deb/Makefile.am b/dpkg-deb/Makefile.am
new file mode 100644
index 0000000..6f118cf
--- /dev/null
+++ b/dpkg-deb/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in
+
+localedir = $(datadir)/locale
+AM_CPPFLAGS = \
+ -DLOCALEDIR=\"$(localedir)\" \
+ -idirafter $(top_srcdir)/lib/compat \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/lib
+
+
+bin_PROGRAMS = dpkg-deb
+
+dpkg_deb_SOURCES = \
+ dpkg-deb.h \
+ build.c \
+ extract.c \
+ info.c \
+ main.c
+
+dpkg_deb_LDADD = \
+ ../lib/dpkg/libdpkg.a \
+ ../lib/compat/libcompat.a \
+ $(LIBINTL) \
+ $(ZLIB_LIBS) \
+ $(BZ2_LIBS)