summaryrefslogtreecommitdiff
path: root/packaging/org.tizen.wallpaper-ui-service.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/org.tizen.wallpaper-ui-service.spec')
-rwxr-xr-xpackaging/org.tizen.wallpaper-ui-service.spec40
1 files changed, 14 insertions, 26 deletions
diff --git a/packaging/org.tizen.wallpaper-ui-service.spec b/packaging/org.tizen.wallpaper-ui-service.spec
index 92c09d4..b5c7d05 100755
--- a/packaging/org.tizen.wallpaper-ui-service.spec
+++ b/packaging/org.tizen.wallpaper-ui-service.spec
@@ -2,7 +2,7 @@
%define RESDIR %{PREFIX}/res
%define PREFIXRW /opt/usr/apps/%{name}
-Name: org.tizen.wallpaper-ui-service-lite
+Name: org.tizen.wallpaper-ui-service
Summary: wallpaper-ui-service window
Version: 0.0.1
Release: 1
@@ -10,6 +10,13 @@ Group: utils
License: Apache-2.0
Source0: %{name}-%{version}.tar.gz
+%if "%{?tizen_profile_name}" == "wearable"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{?tizen_profile_name}"=="tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
BuildRequires: pkgconfig(capi-appfw-application)
BuildRequires: pkgconfig(capi-system-system-settings)
@@ -19,7 +26,7 @@ BuildRequires: pkgconfig(ecore-x)
BuildRequires: pkgconfig(vconf)
BuildRequires: pkgconfig(feedback)
BuildRequires: pkgconfig(tts)
-BuildRequires: pkgconfig(efl-assist)
+BuildRequires: pkgconfig(efl-extension)
BuildRequires: pkgconfig(feedback)
BuildRequires: pkgconfig(ui-gadget-1)
BuildRequires: pkgconfig(notification)
@@ -77,10 +84,9 @@ mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/shared
mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/shared/res
mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/data
mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/data/wallpaper
-mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/data/wallpaper/festival
%define tizen_sign 1
-%define tizen_sign_base /usr/apps/org.tizen.wallpaper-ui-service-lite
+%define tizen_sign_base /usr/apps/org.tizen.wallpaper-ui-service
%define tizen_sign_level platform
%define tizen_author_sign 1
%define tizen_dist_sign 1
@@ -89,22 +95,8 @@ mkdir -p %{buildroot}/opt/usr/apps/org.tizen.wallpaper-ui-service/data/wallpaper
rm -rf %{buildroot}
%post
-GOPTION="-u 5000 -f"
-LOCKOPTION="-s lockscreen_setting::vconf"
-WALLPAPER="-s org.tizen.wallpaper-ui-service::vconf"
-vconftool set -t int db/lockscreen/pre_wallpaper_type 0 $GOPTION $LOCKOPTION
-vconftool set -t string db/lockscreen/pre_bgset "" $GOPTION $LOCKOPTION
-
-vconftool set -t bool db/lockscreen/cp_first_set 1 $GOPTION $WALLPAPER
-vconftool set -t bool db/lockscreen/cp_setpopup_donotshowagain 0 $GOPTION $WALLPAPER
-vconftool set -t bool db/lockscreen/cp_wifipopup_donotshowagain 0 $GOPTION $WALLPAPER
-vconftool set -t bool db/lockscreen/cp_changecategorypopup_donotshowagain 0 $GOPTION $WALLPAPER
-
-vconftool set -t bool db/lockscreen/home_wallpaper_is_default 1 $GOPTION $WALLPAPER
-vconftool set -t int db/lockscreen/wallpaper_type 0 $GOPTION $WALLPAPER
-vconftool set -t int db/lockscreen/wallpaper_count 0 $GOPTION $WALLPAPER
-#usr/bin/signing-client/hash-signer-client.sh -a -d -p platform /usr/apps/org.tizen.wallpaper-ui-service-lite
+#usr/bin/signing-client/hash-signer-client.sh -a -d -p platform /usr/apps/org.tizen.wallpaper-ui-service
%postun -p /sbin/ldconfig
@@ -112,22 +104,18 @@ vconftool set -t int db/lockscreen/wallpaper_count 0 $GOPTION $WALLPAPER
%manifest org.tizen.wallpaper-ui-service.manifest
%defattr(-,root,root,-)
%{PREFIX}/bin/*
-/usr/apps/org.tizen.wallpaper-ui-service-lite/res/locale/*
+/usr/apps/org.tizen.wallpaper-ui-service/res/locale/*
%{RESDIR}/icons/*
%{RESDIR}/edje/*
/usr/share/packages/org.tizen.wallpaper-ui-service.xml
-/usr/apps/org.tizen.wallpaper-ui-service-lite/shared/res/tables/org.tizen.wallpaper-ui-service_color.xml
-/usr/apps/org.tizen.wallpaper-ui-service-lite/shared/res/tables/org.tizen.wallpaper-ui-service_font.xml
/usr/share/license/%{name}
/etc/smack/accesses.d/%{name}.efl
-/usr/apps/org.tizen.wallpaper-ui-service-lite/author-signature.xml
-/usr/apps/org.tizen.wallpaper-ui-service-lite/signature1.xml
-/opt/usr/apps/org.tizen.wallpaper-ui-service-lite/data/wallpaper/festival/*
+/usr/apps/org.tizen.wallpaper-ui-service/author-signature.xml
+/usr/apps/org.tizen.wallpaper-ui-service/signature1.xml
%attr(-,app,app) %dir /opt/usr/apps/org.tizen.wallpaper-ui-service/shared
%attr(-,app,app) %dir /opt/usr/apps/org.tizen.wallpaper-ui-service/shared/res
%attr(-,app,app) %dir /opt/usr/apps/org.tizen.wallpaper-ui-service/data
%attr(-,app,app) %dir /opt/usr/apps/org.tizen.wallpaper-ui-service/data/wallpaper
-%attr(-,app,app) %dir /opt/usr/apps/org.tizen.wallpaper-ui-service/data/wallpaper/festival
%attr(755,app,app)/opt/usr/share/lockscreen
%attr(755,app,app)/opt/usr/share/lockscreen/wallpaper_list