summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules141
1 files changed, 141 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8153a00
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,141 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS ?= -Wall -g
+LDFLAGS ?= -pie
+PREFIX ?= /opt/ug
+DATADIR ?= /opt
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=/usr/lib -Wl,--hash-style=both -Wl,--as-needed
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" cmake .
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ done
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+ rm -rf CMakeCache.txt
+ rm -rf cmake_install.cmake
+ rm -rf Makefile
+ rm -rf install_manifest.txt
+ rm -rf CMakeFiles
+
+ rm -rf popup-wifidirect/CMakeCache.txt
+ rm -rf popup-wifidirect/CMakeFiles
+ rm -rf popup-wifidirect/cmake_install.cmake
+ rm -rf popup-wifidirect/Makefile
+ rm -rf popup-wifidirect/install_manifest.txt
+ rm -rf popup-wifidirect/*.so
+
+ rm -rf ug-wifidirect/CMakeCache.txt
+ rm -rf ug-wifidirect/CMakeFiles
+ rm -rf ug-wifidirect/cmake_install.cmake
+ rm -rf ug-wifidirect/Makefile
+ rm -rf ug-wifidirect/install_manifest.txt
+ rm -rf ug-wifidirect/*.so
+
+ rm -rf popup-wifidirect/po/CMakeCache.txt
+ rm -rf popup-wifidirect/po/CMakeFiles
+ rm -rf popup-wifidirect/po/cmake_install.cmake
+ rm -rf popup-wifidirect/po/Makefile
+ rm -rf popup-wifidirect/po/install_manifest.txt
+ rm -fr popup-wifidirect/po/*.mo
+
+ rm -rf ug-wifidirect/po/CMakeCache.txt
+ rm -rf ug-wifidirect/po/CMakeFiles
+ rm -rf ug-wifidirect/po/cmake_install.cmake
+ rm -rf ug-wifidirect/po/Makefile
+ rm -rf ug-wifidirect/po/install_manifest.txt
+ rm -fr ug-wifidirect/po/*.mo
+
+ rm -rf *.so
+ rm -rf *.desktop
+ rm -rf *.edj
+ rm -rf *.pc
+
+ rm -rf debian/*.install
+ rm -fr debian/temp
+
+ dh_clean
+
+dev_clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+ dh_installman
+ dh_link
+# dh_strip
+ dh_strip --dbg-package=libug-setting-wifidirect-efl-dbg
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+# dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure