summaryrefslogtreecommitdiff
path: root/packaging/starter.spec
diff options
context:
space:
mode:
authorŁukasz Stelmach <l.stelmach@samsung.com>2013-01-03 17:25:54 +0100
committerŁukasz Stelmach <l.stelmach@samsung.com>2013-01-07 14:25:49 +0100
commit7bce162bcdbe363765c8d3c724edded17268fc58 (patch)
tree1d539d799119160520b60ccffad685cc55262a04 /packaging/starter.spec
parenteb7ca0e01c2a1e7bcbdcfe266c21bad2a0705f55 (diff)
downloadstarter-7bce162bcdbe363765c8d3c724edded17268fc58.tar.gz
starter-7bce162bcdbe363765c8d3c724edded17268fc58.tar.bz2
starter-7bce162bcdbe363765c8d3c724edded17268fc58.zip
Introduce path activation for starter programme
It appears interdomain (user session vs. system) dependencies does not work correctly in systemd. amd creates /tmp/amd_ready file when it is ready to accept connections. We can depend on it and start the starter when the file appears. Change-Id: Ie6bd20b31703f6236a10a28d20b0fc68a278d97f Signed-off-by: Łukasz Stelmach <l.stelmach@samsung.com>
Diffstat (limited to 'packaging/starter.spec')
-rwxr-xr-xpackaging/starter.spec7
1 files changed, 5 insertions, 2 deletions
diff --git a/packaging/starter.spec b/packaging/starter.spec
index dd75dbe..450678b 100755
--- a/packaging/starter.spec
+++ b/packaging/starter.spec
@@ -6,6 +6,7 @@ Group: TO_BE/FILLED_IN
License: TO_BE/FILLED_IN
Source0: starter-%{version}.tar.gz
Source1: starter.service
+Source2: starter.path
Requires(post): /usr/bin/vconftool
BuildRequires: cmake
BuildRequires: pkgconfig(ail)
@@ -56,7 +57,8 @@ rm -rf %{buildroot}
mkdir -p %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants
install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/user/
-ln -s ../starter.service %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/starter.service
+install -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/user/
+ln -s ../starter.path %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/starter.path
mkdir -p %{buildroot}/usr/share/license
cp -f LICENSE %{buildroot}/usr/share/license/%{name}
mkdir -p %{buildroot}/opt/data/home-daemon
@@ -105,7 +107,8 @@ sync
/usr/ug/lib/libug-lockscreen-options.so
/usr/ug/lib/libug-lockscreen-options.so.0.1.0
/usr/ug/res/locale/*/LC_MESSAGES/*
+%{_libdir}/systemd/user/starter.path
%{_libdir}/systemd/user/starter.service
-%{_libdir}/systemd/user/core-efl.target.wants/starter.service
+%{_libdir}/systemd/user/core-efl.target.wants/starter.path
/usr/share/license/%{name}
/opt/data/home-daemon