summaryrefslogtreecommitdiff
path: root/lib/ph-front/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ph-front/CMakeLists.txt')
-rwxr-xr-xlib/ph-front/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/lib/ph-front/CMakeLists.txt b/lib/ph-front/CMakeLists.txt
new file mode 100755
index 0000000..bfe93d6
--- /dev/null
+++ b/lib/ph-front/CMakeLists.txt
@@ -0,0 +1,14 @@
+LINK_DIRECTORIES(${CMAKE_BINARY_DIR})
+
+SET(TARGET ${PH_FRONT})
+
+FILE(GLOB SRCS *.c)
+
+ADD_LIBRARY(${TARGET} SHARED ${SRCS})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES VERSION ${VERSION})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES COMPILE_FLAGS ${EXTRA_CFLAGS})
+TARGET_LINK_LIBRARIES(${TARGET} ${COMMON_LIB} ${FAVOR_LIB} ${ug_pkgs_LDFLAGS} ${SPEEDDIAL} ${PH_LOG} ${PH_DIALER} ${CT_DETAILS} ${CT_LIST})
+
+INSTALL(TARGETS ${TARGET} DESTINATION ${UGLIBDIR})
+
+INSTALL(FILES ${CMAKE_BINARY_DIR}/lib/ph-front/phone-tabui-efl.xml DESTINATION "/usr/share/packages")