summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorseong.chung <seong.chung@samsung.com>2014-04-11 18:46:40 +0900
committerSeongwook Chung <seong.chung@samsung.com>2014-04-11 02:50:12 -0700
commit440a3ba5adc834488d03516e29f1ec26b3c5f0c3 (patch)
treedcd47639eee20f923ee3f30b1bc4d4b6005b5f16 /CMakeLists.txt
parent54654ea73876d619ff8df96d2f993bc74faf2f4c (diff)
downloadphone-contacts-440a3ba5adc834488d03516e29f1ec26b3c5f0c3.tar.gz
phone-contacts-440a3ba5adc834488d03516e29f1ec26b3c5f0c3.tar.bz2
phone-contacts-440a3ba5adc834488d03516e29f1ec26b3c5f0c3.zip
Remove SMACK rule file(.rule) according three domain model
Since SMACK only allows three labels, "_"(floor), "User", "System" The labels of current rule file are not appropriate Solution: - Remove rule files -> org.tizen.phone.rule -> org.tizen.contacts.rule -> org.tizen.contacts-appservice.rule -> org.tizen.contacts-viewer.rule - Remove install statement about installing rule file described in CMakeLists.txt - Remove file path and name declaration of spec file (packaging/phone.spec) Reference site https://wiki.tizen.org/wiki/Security:SmackThreeDomainModel Change-Id: Ia8b35549afca9c7735b334655891d04a7188f974 Signed-off-by: seong.chung <seong.chung@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f566cf1..4fe151f 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,10 +60,6 @@ ADD_DEFINITIONS("-DUGDATADIR=\"${UGDATADIR}\"")
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/lib/images/phoneug_images/ DESTINATION ${IMGDIR})
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/lib/images/contact_images/ DESTINATION ${IMGDIR})
INSTALL(DIRECTORY DESTINATION ${DATADIR})
-INSTALL(FILES ${CMAKE_SOURCE_DIR}/org.tizen.phone.rule DESTINATION /opt/etc/smack/accesses.d)
-INSTALL(FILES ${CMAKE_SOURCE_DIR}/org.tizen.contacts.rule DESTINATION /opt/etc/smack/accesses.d)
-INSTALL(FILES ${CMAKE_SOURCE_DIR}/org.tizen.contacts-viewer.rule DESTINATION /opt/etc/smack/accesses.d)
-INSTALL(FILES ${CMAKE_SOURCE_DIR}/org.tizen.contacts-appservice.rule DESTINATION /opt/etc/smack/accesses.d)
ADD_SUBDIRECTORY(lib)
ADD_SUBDIRECTORY(phone)