summaryrefslogtreecommitdiff
path: root/packaging/bluetooth-firmware-bcm.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/bluetooth-firmware-bcm.spec')
-rw-r--r--packaging/bluetooth-firmware-bcm.spec70
1 files changed, 41 insertions, 29 deletions
diff --git a/packaging/bluetooth-firmware-bcm.spec b/packaging/bluetooth-firmware-bcm.spec
index 1018211..c9ae96d 100644
--- a/packaging/bluetooth-firmware-bcm.spec
+++ b/packaging/bluetooth-firmware-bcm.spec
@@ -1,14 +1,15 @@
Name: bluetooth-firmware-bcm
Summary: firmware and tools for bluetooth
# Version/Release/Group are based on mobile package
-Version: 0.2.30
-Release: 0
+Version: 0.2.29
+Release: 1
Group: Hardware Support/Handset
License: Apache-2.0
Source0: bluetooth-firmware-bcm-%{version}.tar.gz
+Source1: bluetooth-hciattach@.service
+Source2: bluetooth-hci-device.service
BuildRequires: cmake
-BuildRequires: model-build-features
%description
firmware and tools for bluetooth
@@ -34,12 +35,12 @@ Group: TO_BE/FILLED
%description msm8974
firmware and tools for bluetooth for redwood msm8974
-%package msm8x26
-Summary: bcm firmware and tools for ms8x26
+%package sprdtrum
+Summary: broadcom firmware and tools for Kiran Spreadtrum
Group: TO_BE/FILLED
-%description msm8x26
-bcm firmware and tools for Rinato 3g msm8x26
+%description sprdtrum
+broadcom bluetooth firmware and tools Kiran Spreadtrum
%prep
%setup -q -n bluetooth-firmware-bcm-%{version}
@@ -48,18 +49,17 @@ bcm firmware and tools for Rinato 3g msm8x26
export CFLAGS+=" -fpie -fvisibility=hidden"
export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
+%if "%{?tizen_profile_name}" == "wearable"
+export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
+%endif
+
%cmake \
%if "%{?tizen_profile_name}" == "wearable"
-%if "%{?model_build_feature_model_name}" == "b2"
- -DTIZEN_WEARABLE_B2=YES \
- -DTIZEN_WEARABLE_B3=NO \
-%elseif "%{?model_build_feature_model_name}" == "b3"
- -DTIZEN_WEARABLE_B2=NO \
- -DTIZEN_WEARABLE_B3=YES \
+ -DTIZEN_WEARABLE=YES \
+%else
+%if "%{?tizen_profile_name}" == "mobile" || "%{?tizen_profile_name}" == "tv"
+ -DTIZEN_WEARABLE=NO \
%endif
-%elseif "%{?tizen_profile_name}" == "mobile"
- -DTIZEN_WEARABLE_B2=NO \
- -DTIZEN_WEARABLE_B3=NO \
%endif
MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
@@ -75,6 +75,9 @@ mkdir -p %{buildroot}/usr/share/license
cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
cat %{_builddir}/%{name}-%{version}/LICENSE.Broadcom >> %{buildroot}/usr/share/license/%{name}
+install -D -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/system/bluetooth-hciattach@.service
+install -D -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-device.service
+
%post c210
rm -rf %{_prefix}/etc/bluetooth/bt-dev-start.sh
ln -s %{_prefix}/etc/bluetooth/bt-dev-start-c210.sh %{_prefix}/etc/bluetooth/bt-dev-start.sh
@@ -87,25 +90,24 @@ ln -s %{_prefix}/etc/bluetooth/bt-dev-start-e4412.sh %{_prefix}/etc/bluetooth/bt
rm -rf %{_prefix}/etc/bluetooth/bt-dev-start.sh
ln -s %{_prefix}/etc/bluetooth/bt-dev-start-msm8974.sh %{_prefix}/etc/bluetooth/bt-dev-start.sh
-%post msm8x26
-rm -rf %{_prefix}/etc/bluetooth/bt-dev-start.sh
-ln -s %{_prefix}/etc/bluetooth/bt-dev-start-msm8x26.sh %{_prefix}/etc/bluetooth/bt-dev-start.sh
-
%files c210
%manifest bluetooth-firmware-bcm.manifest
%defattr(-,root,root,-)
-%{_bindir}/bcmtool
+%{_bindir}/bcmtool_4330b1
%{_bindir}/setbd
%{_prefix}/etc/bluetooth/BCM4330B1_002.001.003.0221.0265.hcd
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-c210.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
/usr/share/license/%{name}
+%exclude %{_libdir}/systemd/system/bluetooth-hciattach@.service
+%exclude %{_libdir}/systemd/system/bluetooth-hci-device.service
%files e4412
%manifest bluetooth-firmware-bcm.manifest
%defattr(-,root,root,-)
-%{_bindir}/bcmtool
+%{_bindir}/bcmtool_4330b1
+%exclude %{_bindir}/bcmtool
%{_bindir}/setbd
%if "%{?tizen_profile_name}" == "wearable"
%{_prefix}/etc/bluetooth/BCM20710A1_001.002.014.0059.0060.hcd
@@ -124,11 +126,14 @@ ln -s %{_prefix}/etc/bluetooth/bt-dev-start-msm8x26.sh %{_prefix}/etc/bluetooth/
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-e4412.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
+%exclude %{_libdir}/systemd/system/bluetooth-hciattach@.service
+%exclude %{_libdir}/systemd/system/bluetooth-hci-device.service
%files msm8974
%manifest bluetooth-firmware-bcm.manifest
%defattr(-,root,root,-)
-%{_bindir}/bcmtool
+%{_bindir}/bcmtool_4330b1
+%exclude %{_bindir}/bcmtool
%{_bindir}/setbd
%{_prefix}/etc/bluetooth/BCM4335B0_002.001.006.0233.0234_ORC_RedWood.hcd
%{_prefix}/etc/bluetooth/BCM4339_003.001.009.0030.0122_ORC_RedWood.hcd
@@ -136,17 +141,24 @@ ln -s %{_prefix}/etc/bluetooth/bt-dev-start-msm8x26.sh %{_prefix}/etc/bluetooth/
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-msm8974.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
/usr/share/license/%{name}
+%exclude %{_libdir}/systemd/system/bluetooth-hciattach@.service
+%exclude %{_libdir}/systemd/system/bluetooth-hci-device.service
+
+%post sprdtrum
+rm -rf %{_prefix}/etc/bluetooth/bt-dev-start.sh
+ln -s %{_prefix}/etc/bluetooth/bt-dev-start-sprdtrum.sh %{_prefix}/etc/bluetooth/bt-dev-start.sh
-%files msm8x26
+%files sprdtrum
%manifest bluetooth-firmware-bcm.manifest
%defattr(-,root,root,-)
%{_bindir}/bcmtool
+%exclude %{_bindir}/bcmtool_4330b1
%{_bindir}/setbd
-%{_prefix}/etc/bluetooth/BCM43342A1_001.002.003.1006.0000_Rintao_G3_ePA.hcd
-%{_prefix}/etc/bluetooth/BCM4334W0_001.002.003.0014.0017_Ponte_Solo_Semco_B58_13.5dBm.hcd
-%{_prefix}/etc/bluetooth/BCM4343A0_001.001.034.0048.0145_ORC_Ponte_Solo-3G.hcd
-%{_prefix}/etc/bluetooth/BCM4343A1_001.002.009.0009.0012_ORC_Ponte_Solo-3G.hcd
+%{_prefix}/etc/bluetooth/BCM4343A0_001.001.034.0058.0215_ORC_Kiran.hcd
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
-%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-msm8x26.sh
+%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start-sprdtrum.sh
%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-set-addr.sh
/usr/share/license/%{name}
+%{_libdir}/systemd/system/bluetooth-hciattach@.service
+%{_libdir}/systemd/system/bluetooth-hci-device.service
+/etc/smack/accesses.d/bluetooth-firmware-bcm.rule