summaryrefslogtreecommitdiff
path: root/packaging/xorg-x11-drv-exynos.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/xorg-x11-drv-exynos.spec')
-rw-r--r--packaging/xorg-x11-drv-exynos.spec80
1 files changed, 50 insertions, 30 deletions
diff --git a/packaging/xorg-x11-drv-exynos.spec b/packaging/xorg-x11-drv-exynos.spec
index 870452b..bfdb207 100644
--- a/packaging/xorg-x11-drv-exynos.spec
+++ b/packaging/xorg-x11-drv-exynos.spec
@@ -1,18 +1,19 @@
# >> macros
# << macros
+%bcond_with ftests=1
+
Name: xorg-x11-drv-exynos
Summary: X.Org X server driver for exynos
-Version: 0.2.112
-Release: 1
-VCS: magnolia/adaptation/ap_samsung/xserver-xorg-video-exynos#xorg-x11-drv-exynos-0.2.79-1-82-g61f4d4f70553099ecf87a5ca00a8dc9a08741871
+Version: 1.0.0
+Release: 3
ExclusiveArch: %arm
Group: System/X Hardware Support
License: MIT
Source0: %{name}-%{version}.tar.gz
BuildRequires: prelink
-BuildRequires: xorg-x11-xutils-dev
+BuildRequires: pkgconfig(xorg-macros)
BuildRequires: pkgconfig(xorg-server)
BuildRequires: pkgconfig(xproto)
BuildRequires: pkgconfig(fontsproto)
@@ -23,56 +24,75 @@ BuildRequires: pkgconfig(resourceproto)
BuildRequires: pkgconfig(libudev)
BuildRequires: pkgconfig(libtbm)
BuildRequires: pkgconfig(xdbg)
-BuildRequires: libdrm-devel
-BuildRequires: libdrm2
-
-%if ("%{tizen_profile_name}" == "wearable" && "%{_repository}" == "target-b3")
-Excludearch: %arm
-%endif
+BuildRequires: pkgconfig(libdrm)
+BuildRequires: pkgconfig(libpng)
+BuildRequires: pkgconfig(dri3proto)
+BuildRequires: pkgconfig(presentproto)
+BuildRequires: pkgconfig(ttrace)
+BuildRequires: pkgconfig(xcb)
+BuildRequires: pkgconfig(xcb-util)
+BuildRequires: pkgconfig(xrandr)
+BuildRequires: pkgconfig(hwaproto)
%description
This package provides the driver for the Samsung display device exynos
-
%prep
%setup -q
-# >> setup
-# << setup
%build
rm -rf %{buildroot}
-# >> build pre
-# << build pre
%if %{?tizen_profile_name} == "wearable"
-export CFLAGS+=" -D_F_WEARABLE_PROFILE_ "
+export CFLAGS+=" -D_F_WEARABLE_FEATURE_ "
%endif
-%reconfigure --disable-static \
- CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
+%if %{with ftests}
+export FTESTS="--enable-ftests"
+%endif
+%autogen --disable-static --enable-hwc --enable-hwa --enable-dri3 \
+ CFLAGS="${CFLAGS} -Wall -Werror -mfpu=neon -g -DLAYER_MANAGER -DHWC_USE_DEFAULT_LAYER \
+ -DUSE_PIXMAN_COMPOSITE -DLEGACY_INTERFACE -DNO_CRTC_MODE -DHWC_ENABLE_REDRAW_LAYER " \
+ LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
make %{?jobs:-j%jobs}
-# >> build post
-# << build post
%install
rm -rf %{buildroot}
-# >> install pre
-# << install pre
mkdir -p %{buildroot}/usr/share/license
cp -af COPYING %{buildroot}/usr/share/license/%{name}
%make_install
-# >> install post
-execstack -c %{buildroot}%{_libdir}/xorg/modules/drivers/exynos_drv.so
-# << install post
+%if %{without ftests}
+ # >> install post
+ execstack -c %{buildroot}%{_libdir}/xorg/modules/drivers/exynos_drv.so
+ # << install post
+%endif
%files
%defattr(-,root,root,-)
-# >> files exynos
-%{_libdir}/xorg/modules/drivers/*.so
-%{_datadir}/man/man4/*
-/usr/share/license/%{name}
-# << files exynos
+%if %{without ftests}
+ %{_libdir}/xorg/modules/drivers/*.so
+ %{_datadir}/man/man4/*
+ /usr/share/license/%{name}
+%else
+ /usr/share/license/%{name}
+
+ # to build functional tests simple add option to gbs "--define with_ftests=1"
+ # Note: if you build functional tests, ddx driver willn't be built
+ %{_libdir}/libdri2_dri3.so
+ %{_bindir}/test_xv
+ %{_bindir}/hwc-sample
+ %{_bindir}/square-bubbles
+ %{_bindir}/clock
+ %{_bindir}/snowflake
+ %{_bindir}/wander-stripe
+ %{_bindir}/hwa_sample
+ %{_bindir}/pixmap_copy
+ %{_datadir}/launch.sh
+
+%post
+ chmod +x %{_datadir}/launch.sh
+%endif