summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules143
1 files changed, 143 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..92a7015
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,143 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+CFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DATADIR ?= /usr
+PREFIX_NS ?= usr
+DATADIR_NS ?= usr
+ARCH ?= $(DEB_HOST_ARCH_CPU)
+ARCH_COMMON ?= $(ARCH)-common
+CONF_FLAGS ?= --with-arch=$(ARCH) --with-conf-prefix=$(DATADIR)
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+configure:
+ ./autogen.sh
+
+config.status: configure
+ dh_testdir
+ # Add here commands to configure the package.
+
+ for f in `find $(CURDIR)/$(ARCH_COMMON)/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ chmod a+x $${f%.in}; \
+ done
+
+ ./configure --prefix=$(PREFIX) $(CONF_FLAGS) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
+
+build-e4412: build-stamp
+ rm -rf $(CURDIR)/debian/tmp/opt/etc/X11/xorg.conf.d*
+
+build-stamp: config.status
+ dh_testdir
+ # Add here commands to compile the package.
+ $(MAKE)
+ #docbook-to-man debian/x11proto-core.sgml > x11proto-core.1
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX_NS)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR_NS)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) distclean
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ rm -f Makefile.in aclocal.m4 config.guess config.sub configure install-sh missing ltmain.sh config.h.in
+
+ for f in `find $(CURDIR)/$(ARCH_COMMON)/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install-common:
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+ mkdir $(CURDIR)/debian/tmp/etc/rc.d/init.d/ -p
+ mkdir $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/ -p
+ mkdir $(CURDIR)/debian/tmp/etc/rc.d/rc4.d/ -p
+ mkdir $(CURDIR)/debian/tmp/etc/profile.d/ -p
+ mkdir $(CURDIR)/debian/tmp/$(PREFIX)/etc/X11/ -p
+ cp -af $(CURDIR)/$(ARCH_COMMON)/xserver $(CURDIR)/debian/tmp/etc/rc.d/init.d/
+ cp -af $(CURDIR)/$(ARCH_COMMON)/xresources $(CURDIR)/debian/tmp/etc/rc.d/init.d/
+ cp -af $(CURDIR)/$(ARCH_COMMON)/xinitrc $(CURDIR)/debian/tmp/usr/etc/X11/
+ ln -s /etc/rc.d/init.d/xserver $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/S02xserver
+ ln -s /etc/rc.d/init.d/xserver $(CURDIR)/debian/tmp/etc/rc.d/rc4.d/S02xserver
+ ln -s /etc/rc.d/init.d/xresources $(CURDIR)/debian/tmp/etc/rc.d/rc3.d/S80xresources
+ ln -s /etc/rc.d/init.d/xresources $(CURDIR)/debian/tmp/etc/rc.d/rc4.d/S80xresources
+ cp -af $(CURDIR)/$(ARCH_COMMON)/Xorg.sh $(CURDIR)/debian/tmp/etc/profile.d/
+
+install-e4412: build-e4412 install-common
+ -cp -af $(CURDIR)/$(ARCH)-e4412/* $(CURDIR)/debian/tmp/$(DATADIR)/etc/X11/ > /dev/null
+
+# Build architecture-independent files here.
+binary-indep:
+# We have nothing to do by default.
+
+binary-e4412: build-e4412 install-e4412
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp -pxserver-xorg-misc-e4412
+ dh_installman
+ dh_link
+ #dh_strip
+ dh_compress
+ dh_fixperms
+ -dh_installdeb -pxserver-xorg-misc-e4412
+ dh_shlibdeps
+ -dh_gencontrol -pxserver-xorg-misc-e4412
+ dh_md5sums
+ -dh_builddeb -pxserver-xorg-misc-e4412
+ #-Nxserver-xorg-misc-sec-c110 -Nxserver-xorg-misc-emulfb
+
+# Build architecture-dependent files here.
+binary-arch: binary-e4412
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install