summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSehong Na <sehong.na@samsung.com>2014-05-31 12:48:52 +0900
committerSehong Na <sehong.na@samsung.com>2014-05-31 12:48:52 +0900
commita461502bac97d35ecf774163c22ca5ed97e1c0bc (patch)
tree88713f4696014c0196f9142aa39f2311d14744d3 /configure.ac
downloadlibtbm-exynos4412-submit/tizen_2.3/20140531.091949.tar.gz
libtbm-exynos4412-submit/tizen_2.3/20140531.091949.tar.bz2
libtbm-exynos4412-submit/tizen_2.3/20140531.091949.zip
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac61
1 files changed, 61 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..56bba62
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,61 @@
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AC_PREREQ(2.60)
+AC_INIT(libtbm-exynos4412, 1.0.0)
+AC_USE_SYSTEM_EXTENSIONS
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_CONFIG_HEADER([config.h])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+AC_HEADER_STDC
+AC_SYS_LARGEFILE
+AC_FUNC_ALLOCA
+
+# Enable quiet compiles on automake 1.11.
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+PKG_CHECK_MODULES(LIBDRM, libdrm)
+PKG_CHECK_MODULES(LIBTBM, libtbm)
+
+LIBTBM_EXYNOS4412_CFLAGS="$LIBDRM_CFLAGS $LIBTBM_CFLAGS "
+LIBTBM_EXYNOS4412_LIBS="$LIBDRM_LIBS $LIBTBM_LIBS "
+AC_SUBST(LIBTBM_EXYNOS4412_CFLAGS)
+AC_SUBST(LIBTBM_EXYNOS4412_LIBS)
+
+bufmgr_dir=${libdir#*/}
+AC_SUBST(bufmgr_dir)
+
+AC_OUTPUT([
+ Makefile
+ src/Makefile])
+
+echo ""
+echo "CFLAGS : $CFLAGS"
+echo "LDFLAGS : $LDFLAGS"
+echo "LIBTBM_EXYNOS4412_CFLAGS : $LIBTBM_EXYNOS4412_CFLAGS"
+echo "LIBTBM_EXYNOS4412_LIBS : $LIBTBM_EXYNOS4412_LIBS"
+echo "bufmgr_dir : $bufmgr_dir"
+echo ""
+