summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSehong Na <sehong.na@samsung.com>2014-05-31 12:46:26 +0900
committerSehong Na <sehong.na@samsung.com>2014-05-31 12:46:26 +0900
commit4cafdb7682d8cc0da627cdaa2a7cc02a25acbbdc (patch)
tree5e072a91141d73b4e4ac87f0c355c380bbf22f5e /src/Makefile.am
downloadlibcamsrcjpegenc-hw-e3250-4cafdb7682d8cc0da627cdaa2a7cc02a25acbbdc.tar.gz
libcamsrcjpegenc-hw-e3250-4cafdb7682d8cc0da627cdaa2a7cc02a25acbbdc.tar.bz2
libcamsrcjpegenc-hw-e3250-4cafdb7682d8cc0da627cdaa2a7cc02a25acbbdc.zip
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..ab80d0c
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,20 @@
+lib_LTLIBRARIES = libcamsrcjpegenc-hw.la
+
+includelibcamsrcjpegenc_hwdir = $(includedir)/camsrcjpegenc
+
+libcamsrcjpegenc_hw_la_SOURCES = camsrcjpegenc-hw-e3250.c
+
+libcamsrcjpegenc_hw_la_CFLAGS = -I$(srcdir)/include \
+ $(GLIB_CFLAGS) \
+ $(CAMSRCJPEGENC_CFLAGS)
+
+libcamsrcjpegenc_hw_la_LIBADD = $(GLIB_LIBS) \
+ $(CAMSRCJPEGENC)
+
+if USE_DLOG
+libcamsrcjpegenc_hw_la_CFLAGS += $(DLOG_CFLAGS)\
+ -DUSE_DLOG
+
+libcamsrcjpegenc_hw_la_LIBADD += $(DLOG_LIBS)
+endif
+